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Preface

Purpose of this document
This Getting Results book provides you with information on how to install and 
navigate the RSLogix 5 software. This guide includes troubleshooting 
information and tips on how to use RSLogix 5 effectively. It also explains how 
to access and navigate the online help.

Intended audience
We assume that you are a control engineer familiar with:

IBM-compliant personal computers
Microsoft® Windows operating systems
Allen-Bradley Company’s PLC-5® programmable controllers
RSLinx™ communications software

Document conventions
This manual uses the following typographical conventions:

[Bold] characters in brackets represent keystrokes used to execute a 
function. When more than one key is to be pressed at a time, the keys are 
separated by a plus sign. For example, [Ctrl + v] means hold down the 
[Ctrl] key and press the [v] key.
Bold characters represent menu choices.
TEXT IN THIS FONT represents characters that you should type.

Online help
If you need help while using RSLogix 5, use any of the following methods:

choose Help from the menu bar.
click the Help button on any RSLogix 5 dialog.
press [F1] on any instruction, dialog box, or window view.

For more information about the online help refer to RSLogix 5 online help on 
page 99.
    iii



Training
Rockwell Software offers both classroom training and a computer-based 
training program for RSLogix 5 software. For more information see RSLogix 5 
training on page 102.

Commonly used terms
The following table defines terms commonly used in this book. 

This term: Represents this concept:

activation files Hidden files in the root folder that allow the software to run. The 
software checks for these files before you have access to offline 
or online programming.

archive Backups of project files. Can be used for version control. 

back up To make a copy of the current file before replacing that file with 
an updated version. 

download Restore a specified file to a specified processor. For example, 
when you download the current project file, you copy the file to 
a specified processor so the processor can begin running that file.

library A file into which you store or from which you retrieve portions 
of ladder logic.

mnemonic A term, usually an abbreviation that is easy to remember. PLC-5 
instructions are typically represented by a 3-letter mnemonic. 

project All of the files that make up the PLC-5 logic program including 
the documentation files.

upload Access a PLC-5 processor and save a copy of the project. 

verification An analysis of the ladder program files that results in the display 
of any  programming errors.

zone Portion of the ladder logic identified by a marker indicating the 
edited state of the file.
iv  •  Getting Results with RSLogix 5™
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Introduction
This chapter explains how to install, activate, and start RSLogix 5 software. 
This chapter includes information on the following:

system requirements
installation methods
activation overview and methods
installation and activation procedure
starting procedures
troubleshooting installation and activation

After installing the software, we recommend that you read the Release Notes. 
The Release Notes may contain more up-to-date information than was 
available when this document was published. To view the Release Notes, start 
the RSLogix 5 software; then, choose Help > RSLogix Release Notes.

System requirements
To use RSLogix 5 effectively, your personal computer must meet the following 
hardware and software requirements:

Hardware requirements
an Intel Pentium II® or greater microprocessor
128 MB of RAM for Windows 2000, or Windows XP installations 
70 MB of available hard disk space
256-color SVGA graphics adapter with 800x600 resolution
a CD-ROM drive

Chapter

1 Installing and activating 
RSLogix 5

Important To install RSLogix 5, you must have administrator privileges for the 
computer. For more information, contact your system 
administrator.
Installing and activating RSLogix 5   • 1



a 3.5-inch, 1.4 MB disk drive (required only for activation, therefore, it is not 
required on client machines in a client-server installation)
any Windows-compatible mouse or other pointing device

We recommend a 500-MHz Pentium computer with 128MB RAM or greater 
for optimal performance.

Software requirements
The operating system must be one of the following:

Microsoft Windows 2000
Windows XP (with or without Service Pack 2)
Windows Server 2003 (with or without Service Pack 1)
Windows Server 2003 R2
RSLogix 5 will not run on earlier versions of Windows, nor will it run on 
Windows Vista.
RSLogix 5 relies on RSLinx Classic™ communication software, version 
2.51.00 or later. One copy of the RSLinx Classic Lite software is included 
with the RSLogix 5 software. 

Activation
Software activation is a process by which you identify that you have installed a 
legitimate copy of RSLogix 5 on your computer. Activation works through an 
activation file that indicates to the software that you are using the software 
legitimately.
There are two forms of activation supported by RSLogix 5:

EVMOVE activation, which uses a master disk to deliver an activation file 
to your computer
FactoryTalk Activation, which allows you to download an activation file 
through an Internet connection

For new installations of RSLogix 5, you must use FactoryTalk Activation to 
activate the software. 
2  •   Getting Results with RSLogix 5™



If you are upgrading a current installation of RSLogix 5, you may continue 
to use your EVMOVE activation. However, future versions of RSLogix 5 
will require you to use FactoryTalk Activation. Rockwell Software advises 
you to activate your software using FactoryTalk Activation now.

Installing RSLogix 5 software
Installing RSLogix 5 software involves installing and configuring the following 
software packages:

Installing RSLinx Classic Lite software (if you do not have RSLinx 
Classic already installed on your computer)
Installing the FactoryTalk Automation Platform (if you intend to use 
FactoryTalk Security to control access to features of RSLogix 5 – in this case, 
you will also need to configure FactoryTalk Security to allow users to access 
the software)
Installing the FactoryTalk Activation Client (if you have a new RSLogix 
5 installation or need to upgrade your activation to FactoryTalk Activation. 
If you intend to continue using EVMOVE activation for now, you do not 
have to install this software.)
Installing the Security Server Client (if you intend to use the Rockwell 
Software Security Server to control access to features of RSLogix 5 – in this 
case, you will also need to configure your Security Server to allow users to 
access the software. Rockwell Software advises that you use FactoryTalk 
Security instead of the Security Server to provide security functions)
Configuring FactoryTalk Security to permit access to features of RSLogix 
5
RSLogix 5 software

Installing RSLinx Classic Lite software
If you have RSLinx

Classic 2.51 or
later installed, you

do not need to
install RSLinx

Classic Lite.

RSLinx Classic Lite provides communication between the programmable 
controller and a personal computer.
To install RSLinx Classic Lite software: 
1. Log onto the computer as an administrator or as a user with 

administrative privileges.

Tip Future versions of RSLogix 5 will require using FactoryTalk 
Activation to activate the software. Rockwell Software strongly 
suggests that you activate your software with FactoryTalk Activation 
now to prevent difficulties with future versions of the software.
Installing and activating RSLogix 5   •  3



2. Insert the RSLogix 5 CD-ROM into the CD-ROM drive. The installation 
program should start automatically. If it does not, open the installation 
disk with Windows Explorer and run AUTORUN.EXE.

3. Click Required Steps, and then click Install RSLinx Lite.
4. Follow the directions that appear on the screen.

Installing the FactoryTalk Automation Platform

To install the FactoryTalk Automation Platform:
1. Log onto the computer as an administrator or as a user with 

administrative privileges.
2. Insert the RSLogix 5 CD-ROM into the CD-ROM drive. The installation 

program should start automatically. If it does not, open the installation 
disk with Windows Explorer and run AUTORUN.EXE.

3. Click Required Steps, and then click Install FactoryTalk Components. 
4. Click Install FactoryTalk Automation Platform.
5. Follow the on-screen instructions to install the FactoryTalk Automation 

Platform.

Caution If you are upgrading the FactoryTalk Automation Platform, see 
Upgrading the FactoryTalk Platform on page 10 for important 
information.

Tip The FactoryTalk Automation Platform is required for using 
FactoryTalk Security with RSLogix 5. It does not serve any other 
purpose with regard to RSLogix 5, however, it is used with a variety 
of other Rockwell Software products. 
If you have already installed the FactoryTalk Automation Platform 
for the current release (the CPR number indicates the release), you 
do not need to install it again.

Tip The setup program will ask if you want to install the FactoryTalk 
Administration Console. The Administration Console allows you to 
configure your FactoryTalk Directory. You will need to have the 
Administration Console available on at least one computer so you 
can configure FactoryTalk Security (and perform other tasks in the 
FactoryTalk Directory). 
If you will be using FactoryTalk Security only locally, you must 
install the Administration Console.
4  •   Getting Results with RSLogix 5™



6. After the FactoryTalk Automation Platform is installed, the FactoryTalk 
Directory Configuration Wizard starts. This wizard allows you to 
configure your FactoryTalk directory. 
On the first screen of the FactoryTalk Directory Configuration Wizard, 
you need to choose whether you want to install the FactoryTalk Network 
Directory, the FactoryTalk Local Directory, or both. If you will be using 
the computer to access another FactoryTalk Directory Server for 
FactoryTalk Security, or if other computers will be accessing your 
computer for FactoryTalk Security, you must install the FactoryTalk 
Network Directory. 
If you will be using FactoryTalk Security only on the local computer – with 
no other computers accessing the computer for security information – you 
can install the FactoryTalk Local Directory. 
You can install both the FactoryTalk Network Directory and the 
FactoryTalk Local Directory.

Installing the FactoryTalk Activation Client

To install the FactoryTalk Activation Client:
1. Log onto the computer as an administrator or as a user with 

administrative privileges.

Tip Using FactoryTalk Security on the local directory does not require 
activation. 
On a network directory, FactoryTalk Security does not require 
activation for ten or fewer users. If you intend to have more than ten 
users (including administrative users) on a network directory, you 
must purchase and activate FactoryTalk Security licenses for the 
additional users.

Tip The FactoryTalk Activation Client is used to activate RSLogix 5 
software. If you have a current installation of RSLogix 5 that uses 
EVMOVE activation, you may continue to do so. However, future 
versions of RSLogix 5 will no longer support EVMOVE activation. 
Rockwell Software advises you to upgrade to FactoryTalk Activation 
to avoid problems with future releases of RSLogix 5.
If you have already installed the FactoryTalk Activation Client for 
the current release (the CPR number indicates the release), you do 
not need to install it again.
Installing and activating RSLogix 5   •  5



2. Insert the RSLogix 5 CD-ROM into the CD-ROM drive. The installation 
program should start automatically. If it does not, open the installation 
disk with Windows Explorer and run AUTORUN.EXE.

3. Click Required Steps, and then click Install FactoryTalk Components. 
4. Click Install FactoryTalk Activation Client.
5. Follow the on-screen instructions to install the FactoryTalk Activation 

Client.
6. After the installation is finished, the FactoryTalk Activation Tool and 

FactoryTalk Activation Wizard both launch. The FactoryTalk Activation 
Tool allows you to manage the activations on your computer and obtain 
new activations. The FactoryTalk Activation Wizard is a simpler method 
for obtaining activations.
Use the Activation Tool or the Activation Wizard to obtain your activation 
for RSLogix 5. If you need help in obtaining activations, or if you need to 
learn more about the process of activating Rockwell Software products, 
click Start > Programs > Rockwell Software > FactoryTalk 
Activation > FactoryTalk Activation Help (or click the Help button in 
the FactoryTalk Activation Tool).

Supported activation types for RSLogix 5
RSLogix 5 supports the following types of FactoryTalk Activation:

Node-locked, either to a computer or to a dongle. With this activation type, 
the software is locked to a specific computer or to a dongle that can be 
moved from one computer to another.
Concurrent, where the activation resides on a FactoryTalk Activation 
server. Computers running RSLogix 5 then use the activations from the 
server, releasing the activations when they are not in use. Computers can also 
“borrow” activations if they are not going to remain connected to the 
network.

Tip Your computer must be connected to the Internet to be able to 
obtain activations directly using the Activation Tool or Activation 
Wizard. You can obtain the activation using a different computer 
than the one you are actually activating. 
It is also possible to obtain activations by phone or fax. See the 
FactoryTalk Activation help file for more information (click Start > 
Programs > Rockwell Software > FactoryTalk Activation > 
FactoryTalk Activation Help).
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For more information about activation types, see the FactoryTalk Activation 
Help file (click Start > Programs > Rockwell Software > FactoryTalk 
Activation > FactoryTalk Activation Help (or click the Help button in the 
FactoryTalk Activation Tool).

Installing the Security Server Client

To install the Security Server Client:
1. Log onto the computer as an administrator or as a user with 

administrative privileges.
2. Insert the RSLogix 5 CD-ROM into the CD-ROM drive. The installation 

program should start automatically. If it does not, open the installation 
disk with Windows Explorer and run AUTORUN.EXE.

3. Click Optional Steps, and then click Security Server Client. 
4. Follow the on-screen instructions for installing the Security Server Client.
5. During the Security Server Client installation, the Rockwell Software’s 

Security Server Definitions window appears. This window allows you to 
define what Security Server(s) the client will access for security 
information. If you need help configuring a list of servers, click the Help 
button on this window. If you do not know which Security Server(s) to 
use, ask your Security Server administrator.

Tip Install the Security Server Client software only if you are already 
using a Rockwell Software Security Server to control access to 
features of RSLogix 5.
If you do not already have a Rockwell Software Security Server 
running in your facility and want to secure access to features of 
RSLogix 5, Rockwell Software advises you to use FactoryTalk 
Security instead of the Security Server. 
If you already have a Security Server in your facility, you may install 
the Security Server Client software. However, Rockwell Software 
advises that future releases of RSLogix 5 will no longer support the 
Security Server. Security functions will be supplied through 
FactoryTalk Security.
Installing and activating RSLogix 5   •  7



6. When the Enable/Disable Security Keys window appears:
a. If you are certain that you have a functioning Security Server that is 

configured to allow users access to the features of RSLogix 5, check 
the RSLogix 5 or RSLogix 5 Pro boxes (the box you need to check 
depends on whether you are installing RSLogix 5 or RSLogix 5 
Professional). Checking these boxes indicates that you want to enable 
security for the software. 

b. Do not check boxes for any other product. (If a box is already 
checked, you will not be able to uncheck it.)

Installing RSLogix 5 software
To install RSLogix 5 software, perform the following steps:
1. Log onto the computer as an administrator or as a user with 

administrative privileges.
2. Insert the RSLogix 5 CD-ROM into the CD-ROM drive. The installation 

program should start automatically. If it does not, open the installation 
disk with Windows Explorer and run AUTORUN.EXE.

3. Click Required Steps, and then click Install RSLogix 5.
4. Follow the instructions that appear on the screen to install the software.
5. If you installed the FactoryTalk Automation Platform: During the 

installation, the setup program displays a window asking if you want to 
enable FactoryTalk Security. 

If you do not want to use FactoryTalk Security to control user access to 
function of RSLogix 5, make sure the Enable FactoryTalk Security box 
is unchecked, and then click Next. 

Caution Do not enable security unless you are certain that the Security Server 
will be configured to permit user access to RSLogix 5 actions. If the 
Security Server is not configured, users will not be able to use 
RSLogix 5!

Caution If you enable support for FactoryTalk Security, you must configure 
FactoryTalk Security before users will be able to use RSLogix 5. For 
information about configuring FactoryTalk Security, see Configuring 
FactoryTalk Security for RSLogix 5 on page 15. 
If you accidentally enable FactoryTalk Security and wish to disable 
it, you must uninstall RSLogix 5 and re-install it.
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If you want to use FactoryTalk Security to control user access to functions 
of RSLogix 5:
a. Check the Enable FactoryTalk Security box.

b. Select whether you want to use the local directory or the network 
directory to authenticate user access and security credentials. If you 
use the local directory, users on other computers are unaffected by 
FactoryTalk Security. To be able to authenticate users from remote 
computers, you must use the network directory. (You do not need to 
activate FactoryTalk Security if you use the local directory.)

c. Click Next. 
d. The setup program asks you to log onto the FactoryTalk Directory. 

You must log on using an administrative account. Enter your 
FactoryTalk directory user name and password, and then click Next.

Tip If you have used the Rockwell Software Security Server to control 
user access to functions of RSLogix 5 and you have enabled 
FactoryTalk Security, you can import your Security Server database 
into FactoryTalk Security. 
See Importing a Security Configuration from the Rockwell Software 
Security Server into FactoryTalk Security on page 14 for more 
information.
Installing and activating RSLogix 5   •  9



Upgrading the FactoryTalk Platform
If you are upgrading the FactoryTalk Platform, there are procedures you must 
follow to ensure that the platform will function properly.

Upgrading a Stand-Alone System on a Single 
Computer
To upgrade the automation system software on a stand-alone system that uses 
a FactoryTalk Local Directory on a single computer, follow the steps below.

1. On the stand-alone computer where an earlier version of FactoryTalk 
Automation Platform is installed, shut down all running software 
products, and then uninstall all Rockwell Software products that 
depend on FactoryTalk, such as RSView SE Station, RSView ME, RSLinx 
Classic, RSLogix products, and so on.

2. Install FactoryTalk Automation Platform v. 2.10.00.
The installation program prompts you for confirmation, and then un-
installs the earlier version of the FactoryTalk software before installing the 
new version.

3. When the installation finishes, the FactoryTalk Directory Configuration 
Wizard runs. On the first screen, click Next to select the default option, 
"Configure FactoryTalk Local Directory."

4. At the prompt to create an administrator account for this Local Directory, 
either:

Click Next to accept default user name and leave password blank 
— recommended if you plan to override security services.
Enter a user name and password — recommended if you plan to 
secure your system with FactoryTalk Security. Remember that the 
password is case sensitive. 

5. Whether you accept the default user name and password entries or create 
your own, write this information down and keep it in a safe place. You will 
need these credentials to access the Local Directory and to log on to 
FactoryTalk Administration Console. 

6. At the prompt to select who has full access to the Local Directory, choose 
either:
All users — recommended if you plan to override security services.

Caution Uninstall all FactoryTalk-enabled products before uninstalling and 
reinstalling the FactoryTalk Automation Platform.
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Only administrators — recommended if you plan to secure your 
system with FactoryTalk Security.

7. When the FactoryTalk Directory Configuration Wizard finishes, install the 
software products that you plan to use in your stand-alone automation 
system. 
All of the participating FactoryTalk-enabled software products must also 
be upgraded to versions that support Coordinated Process Release (CPR) 
7. For details, consult each product's installation documentation.

Upgrading a Distributed FactoryTalk System on a 
Network
To upgrade the automation system software on a distributed system that uses 
a FactoryTalk Network Directory across networked computers, follow the 
steps below.

Upgrade FactoryTalk Automation Platform on the Network Directory 
Server computer
Add computer accounts to the Network Directory Server

Upgrade FactoryTalk Automation Platform on the remote client 
computers

Upgrade FactoryTalk Automation Platform on the Network Directory 
Server Computer
1. On the computer that is hosting the FactoryTalk Network Directory 

Server, shut down all running software products, and then uninstall all 
Rockwell Software products that depend on FactoryTalk, such as 
RSView SE Distributed, RSLinx Classic, RSLinx Enterprise, RSLogix 
products, RSSql, and so on.

2. Install FactoryTalk Automation Platform v. 2.10.00.
The installation program prompts for confirmation, and then un-installs 
the earlier version of the FactoryTalk software before installing the new 
version.

3. When the installation finishes, the FactoryTalk Directory Configuration 
Wizard runs. On the first screen, select the check box, "Configure 
FactoryTalk Network Directory," either accept or clear the check box, 
"Configure FactoryTalk Local Directory," and then click Next to 
continue.

Caution Uninstall all FactoryTalk-enabled products before uninstalling and 
reinstalling the FactoryTalk Automation Platform.
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In most cases, you do not need to configure a Local Directory when 
upgrading a distributed system. To configure only a Network Directory, 
clear the "Configure FactoryTalk Local Directory" check box.
If you plan to install RSBizWare Batch software on this computer, or if 
you plan to install other stand-alone software, then you need both a 
Network Directory and Local Directory configured on this computer. 
Leave the "Configure FactoryTalk Local Directory" check box selected.

4. At the prompt to create an administrator account for this Network 
Directory, enter a user name and password, and then write this 
information down and keep it in a safe place. You will need these 
credentials to access the Network Directory and to log on to FactoryTalk 
Administration Console.

Passwords are case sensitive.
If you are configuring both a Network Directory and a Local Directory, 
you will be prompted to create separate administrator accounts for each 
directory.

5. At the prompt to select who has full access to the Network Directory, 
choose either:

Only administrators — recommended if you plan to secure your 
system with FactoryTalk Security.
All users — if you plan to override security by allowing all users full 
access to your system.

6. Follow the steps in the wizard to finish configuring a Network Directory 
(and optional Local Directory) on this computer.

7. Next, add a computer account to the Network Directory Server for each 
remote client computer that is part of your distributed system. See the 
steps below.

Add computer accounts to the Network Directory Server
1. After installing FactoryTalk Automation Platform and configuring a 

Network Directory, run FactoryTalk Administration Console from the 
Windows Start menu: Start > Programs > Rockwell Software > 
FactoryTalk Administration Console. 

2. At the prompt to choose a FactoryTalk Directory, choose Network, and 
then log on, using the administrator user name and password you created 
when you configured the directory.

3. In the Administration Console Explorer pane, open Network > System 
> Computers and Groups > Computers. Create a computer account 
for each remote client computer that is part of your distributed 
automation system. For help, click the Help button on any dialog.
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4. Log off FactoryTalk Administration Console (File > Log off), and then 
log off FactoryTalk (Start > Programs > Rockwell Software > 
FactoryTalk Tools > Log On to FactoryTalk).

5. Next, upgrade FactoryTalk Automation Platform on the client computers 
that are part of your networked system. See the steps below.

Upgrade FactoryTalk Automation Platform on the Remote Client 
Computers
1. On each of the client computers in your distributed system, shut 

down all running software products, and then uninstall all Rockwell 
Software products that depend on FactoryTalk, such as RSView SE 
Distributed, RSLinx Classic, RSLinx Enterprise, RSLogix products, RSSql, 
and so on.

2. On each of the client computers, install FactoryTalk Automation Platform 
v. 2.10.00.
The installation program prompts for confirmation, and then un-installs 
the earlier version of the FactoryTalk software before installing the new 
version.

3. When the installation finishes, the FactoryTalk Directory Configuration 
Wizard runs. On each screen, select the same options that you selected 
when you configured the FactoryTalk Network Directory on the Network 
Directory Server computer. 

On the first screen, select the check box, "Configure FactoryTalk 
Network Directory," either accept or clear the check box, "Configure 
FactoryTalk Local Directory." 
At the prompt to create an administrator account, enter the user name 
and password of the administrator account you created when you 
configured the directory on the Network Directory Server computer. 
(Passwords are case sensitive.)

4. Next, on the various client computers on your network, reinstall the 
software products that you plan to use in your distributed automation 
system. 
All of the participating FactoryTalk-enabled software products must also 
be upgraded to versions that support Coordinated Process Release (CPR) 
7. For details, refer to each product's installation documentation.
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Importing a Security Configuration from the Rockwell 
Software Security Server into FactoryTalk Security

If you have used the Rockwell Software Security Server to control access to 
user actions in RSLogix 5 and you have enabled FactoryTalk Security, you can 
import your security configuration from the Security Server into FactoryTalk 
Security. The import process will import your users, user groups, and ACLs 
from the Security Server, saving you time.

To import the security configuration from the Rockwell Software Security 
Server into FactoryTalk Security:
1. Because the import process writes to the FactoryTalk directory, it is 

important that you backup your FactoryTalk Directory before beginning 
the import.
a. Run the FactoryTalk Administration Console by clicking Start > 

Programs > Rockwell Software > FactoryTalk Administration 
Console.

b. Log onto the FactoryTalk Directory where you are using FactoryTalk 
Security.

c. Right-click the top-level object in the Explorer tree (this is the 
Network or Local object, depending on whether you are viewing the 
Network or Local directory), and then click Backup.

d. In the Backup window, type a name for the backup file in the Specify 
archive name field. In the Specify archive location field, enter the 
path to where you want to save the backup file. You can click the 
browse( ... ) button to browse for a folder.

e. Click OK.
2. In the Rockwell Software Security Server Configuration Explorer, export 

your security database to a file by clicking File > Export Database.
3. After exporting the database, close the Configuration Explorer.
4. Click Start > Programs > Rockwell Software > FactoryTalk Tools > 

Import RSSecurity Configuration. This starts the FactoryTalk Security 
Import utility.

5. In the import utility, enter the path to the file you exported from the 
Security Server in the Select RS Security Server backup database to 
import field. If you prefer, click Browse and locate the file.

Tip After importing your security configuration into FactoryTalk 
Security, uninstall the Security Server.
14  •   Getting Results with RSLogix 5™



6. From the Destination Directory pull-down list, select the FactoryTalk 
Directory that you are using with FactoryTalk Security (Network or 
Local).

7. If you have actions in your Security Server database that do not have 
security rights granted or denied, you can grant access to those actions to 
users by default by checking the Add implicitly grant access box. If you 
do not check this box, those actions will be denied to users by default.

8. If you want to display a log file of what happens during the import, check 
the Display log on completion box.

9. Click OK.
10. The import utility warns that you should back up your FactoryTalk 

Directory. If you have not done so, do so now (see step 1). If you have 
backed up your FactoryTalk Directory, click Yes.

11. Log onto the FactoryTalk Directory where you will be using FactoryTalk 
Security.

12. The import process runs. Depending on the contents of the file you are 
importing and of your FactoryTalk Directory, you may receive a warning 
message during the import. If this happens, review the information and 
click OK to continue the import process. 

13. When the process is complete, the import utility displays a window saying 
whether it was successful or unsuccessful. Click OK.

14. If you chose to display a log file at the end of the import, the log file 
opens. 

Configuring FactoryTalk Security for RSLogix 5
FactoryTalk Security allows you to control who can access features and 
functions of RSLogix 5. 
There are two methods for controlling access to the features and functions of 
RSLogix 5:

Policies, which are features and functions that are controlled globally. When 
you set access rights to an RSLogix 5 policy, those rights affect users without 
respect to the controllers they are using.
Actions, which are features and functions that can be secured globally, but 
can also be set on a controller-by-controller basis. 
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For example, we want to determine whether a user named Bob may use a given 
function of RSLogix 5. To answer that question, we have to know whether the 
feature is secured through a policy or through an action. If it is secured through 
an action, we need to know whether the controller Bob is using inherits its 
security settings from the global settings for RSLogix 5.

Setting Security Policies for RSLogix 5
Security policies control features globally. If a user is granted access to a feature 
of RSLogix 5 that is controlled by a policy, that user can use the feature 
regardless of the controller the user is using.

Is the feature secured
by a policy or by

an action?

Does the
controller Bob is using

inherit security for actions from 
the global action settings for

RSLogix 5?

Action

Policy

The setting in the 
policy for RSLogix 5 
determines whether 

Bob may use the 
feature.

Controller
inherits

Controller does
not inherit

The action security 
setting for the 

controller determines 
whether Bob may use 

the feature.

The global action 
setting for RSLogix 5 
determines whether 

Bob may use the 
feature.
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RSLogix 5 security policies control the following features:

This policy: If granted to a user: If denied to a user:

Allow the installation of 
RSLogix 

Permits the user to install 
RSLogix 5.

Prevents the user from 
installing RSLogix 5.

Allow the un-installation 
of RSLogix 

Permits the user to 
uninstall RSLogix 5.

Prevents the user from 
uninstalling RSLogix 5.

Change Report Settings Permits the user to 
change reporting settings.

Prevents the user from 
changing reporting 
settings.

Change Software 
Properties 

Permits the user to access 
and change the software 
configuration options 
(the Tools > Options 
menu item). Also allows 
access to the properties 
for ladder files, data table 
files, force files, and 
database files.

Prevents the user from 
accessing or changing 
software configuration 
options.

Compare Utility Permits the user to use 
the Compare utility.

Prevents the user from 
using the Compare utility.

Enable VBA Editor 
(RSLogix 5 Professional 
only)

Permits the user to use 
the Visual Basic for 
Applications (VBA) 
editor.

Prevents the user from 
using the VBA editor.

Enable/Disable VBA 
(RSLogix 5 Professional 
only)

Permits the user to run 
VBA scripts.

Prevents the user from 
running VBA scripts.

Generate Report Permits the user to 
generate reports.

Prevents the user from 
generating reports.

Prompt for audit 
comment on File New 

RSLogix 5 prompts the 
user for a comment when 
creating a new file (if 
RSLogix 5 is configured 
to audit user actionsa).

The user is not prompted 
for a comment when 
creating a new file.

Prompt for audit 
comment on File Open 

RSLogix 5 prompts the 
user for a comment when 
opening a file (if RSLogix 
5 is configured to audit 
user actionsa).

The user is not prompted 
for a comment when 
opening a file.
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To set security policies for RSLogix 5:
1. Start the FactoryTalk Administration Console by clicking Start > 

Programs > Rockwell Software > FactoryTalk Administration 
Console. 

2. If you are not automatically logged onto the FactoryTalk Directory 
Server, log onto the server when prompted to do so. You must log onto 
the FactoryTalk Directory using an administrator account (or an account 
that has the rights to change security settings).

3. Once you are logged onto the server, click the System > Policies > 
Product Policies > RSLogix 5 folder, and then open the Feature 
Security object.

Prompt for audit 
comment on File Save 

RSLogix 5 prompts the 
user for a comment when 
saving a file (if RSLogix 5 
is configured to audit user 
actionsa).

The user is not prompted 
for a comment when 
saving a file.

a. To enable auditing, you will need to install the optional source control software for 
RSLogix 5. This software is available from Rockwell Software Technical Support.

Tip To be able to use RSLogix 5, users (or user groups) must have the 
Read right to the Feature Security object for RSLogix 5. (To 
configure security for RSLogix 5, users must be FactoryTalk 
administrators.) 
If users do not have the Read right to the Feature Security object, the 
FactoryTalk Directory will not allow them to read what rights they 
have in RSLogix 5, and secured features will not function for those 
users.

This policy: If granted to a user: If denied to a user:
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4. The Feature Security Properties window appears. In this window, click the 
function to which you want control access, and then click the small button 
(labeled ...) that appears on the right side of the window. 

5. Configure the access for the function.
If you need more information about configuring FactoryTalk Security, click the 
Help button on the Feature Security Properties window.

Securing Actions for RSLogix 5
Secured actions are functions that are secured either globally (affecting all 
controllers) or that are secured on a controller-by-controller basis. Whether the 
security settings apply globally or not depends on whether controllers inherit 
their security settings from the Networks and Devices object in the 
FactoryTalk Directory.

Click the function to which 
you want to control access

Click the small button (…) 
that appears on the right side 
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The following actions can be secured for RSLogix 5:

This action: If granted to a user:

Change ControlNet XC File Association The user may change the XC file 
association for a controller.

Change Password/Privilege Settings The user may change a controller's 
password/privilege settings.

Change Privilege Class The user may change privilege classes 
for a controller.

Change Processor Mode The user may change controller modes.

Clear Fault The user may clear processor faults.

Clear Memory The user may clear controller memory.

Communications Configuration The user may configure controller 
communications.

Configure Hot-Backup The user may configure the hot backup 
feature for a controller.

Create/Delete Custom Data Monitor The user may create or delete custom 
data monitors.

Create/Delete Data Files The user may create or delete data table 
files.

Create/Delete Program Files The user may create or delete program 
files.

Create/Delete Recipe Templates The user may create or delete recipe 
templates.

Create/Delete Trend The user may create or delete trends.

Create/Delete/Modify User Defined 
Structures

The user may create, delete, and modify 
user defined data structures.

Data File Properties The user may set the properties of data 
table files.

Data Table Modification The user may modify data table files.

Database Import/Export The user may import and export 
description databases.

Description Editing The user may edit the description 
database.

Download The user may download to a controller.
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Force Functions The user may force I/O or modify 
forces.

Go Online The user may go online with a controller.

Load/Delete Logic Extension Modules The user may load or delete Logic 
Extension Modules (LEMs)

Monitor Custom Data Monitors The user may monitor custom data 
monitors.

Monitor Recipe Templates The user may monitor recipe templates.

Monitor Trend The user may monitor trends.

Offline Data File Monitoring The user may monitor data table files 
while offline.

Offline Program File Editing The user may modify program files while 
offline.

Offline Program File Monitoring The user may monitor program files 
while offline.

Online Data File Monitoring The user may monitor data table files 
while online.

Online Program File Editing The user may modify program files while 
online.

Online Program File Monitoring The user may monitor program files 
while online.

Partial Download The user may use the partial download 
feature.

Prevent Factory Password Override The user may override a controller’s 
password using the factory override 
password.

Program File Properties The user may set the properties of 
program files.

Prompt for audit comment on applying 
port configuration

If auditing is enableda, the user will be 
prompted for a comment when applying 
changes to controller port 
configurations.

Prompt for audit comment on 
Assembling Pending Edits

If auditing is enableda, the user will be 
prompted for a comment when 
assembling pending rung edits.

This action: If granted to a user:
Installing and activating RSLogix 5   •  21



Prompt for audit comment on Changing 
Password

If auditing is enableda, the user will be 
prompted for a comment when 
changing a controller password.

Prompt for audit comment on Changing 
Processor Mode

If auditing is enableda, the user will be 
prompted for a comment when 
changing controller mode.

Prompt for audit comment on Channel 
Configuration Data

If auditing is enableda, the user will be 
prompted for a comment when 
changing controller channel 
configuration data.

Prompt for audit comment on Clearing 
all forces

If auditing is enableda, the user will be 
prompted for a comment when clearing 
all forces in a controller.

Prompt for audit comment on Clearing 
Faults

If auditing is enableda, the user will be 
prompted for a comment when clearing 
controller faults.

Prompt for audit comment on Clearing 
Memory

If auditing is enableda, the user will be 
prompted for a comment when clearing 
controller memory.

Prompt for audit comment on Deleting 
Data File

If auditing is enableda, the user will be 
prompted for a comment when deleting 
a data file.

Prompt for audit comment on Deleting 
Program File

If auditing is enableda, the user will be 
prompted for a comment when deleting 
a program file.

Prompt for audit comment on Disabling 
all forces

If auditing is enableda, the user will be 
prompted for a comment when disabling 
all forces.

Prompt for audit comment on Disabling 
SFC forces

If auditing is enableda, the user will be 
prompted for a comment when disabling 
SFC forces.

Prompt for audit comment on 
Downloading program from Processor

If auditing is enableda, the user will be 
prompted for a comment when 
downloading a program from a 
controller.

Prompt for audit comment on Enabling 
all forces

If auditing is enableda, the user will be 
prompted for a comment when enabling 
all forces.

This action: If granted to a user:
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Prompt for audit comment on Enabling 
SFC forces

If auditing is enableda, the user will be 
prompted for a comment when enabling 
SFC forces.

Prompt for audit comment on extended 
force data clearing

If auditing is enableda, the user will be 
prompted for a comment when clearing 
external force files.

Prompt for audit comment on extended 
force data configuration

If auditing is enableda, the user will be 
prompted for a comment when 
configuring external forces.

Prompt for audit comment on Going 
Offline

If auditing is enableda, the user will be 
prompted for a comment when going 
offline.

Prompt for audit comment on Going 
Online

If auditing is enableda, the user will be 
prompted for a comment when going 
online with a controller.

Prompt for audit comment on I/O auto 
configuration

If auditing is enableda, the user will be 
prompted for a comment when 
autoconfiguring I/O.

Prompt for audit comment on Inserting 
a Replacement Rung

If auditing is enableda, the user will be 
prompted for a comment when inserting 
a replacement ladder logic rung.

Prompt for audit comment on Inserting 
a Rung

If auditing is enableda, the user will be 
prompted for a comment when inserting 
a rung into a ladder logic program.

Prompt for audit comment on Inserting 
Data File

If auditing is enableda, the user will be 
prompted for a comment when creating 
a data table file.

Prompt for audit comment on Inserting 
Program File

If auditing is enableda, the user will be 
prompted for a comment when creating 
a program file.

Prompt for audit comment on Loading 
from EEPROM

If auditing is enableda, the user will be 
prompted for a comment when loading 
a program from EEPROM.

Prompt for audit comment on Marking 
Rung for Deletion

If auditing is enableda, the user will be 
prompted for a comment when marking 
a rung for deletion.

This action: If granted to a user:
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Prompt for audit comment on Online 
Ladder Edits

If auditing is enableda, the user will be 
prompted for a comment when editing 
ladder logic while online.

Prompt for audit comment on Partial 
Downloading program from Processor

If auditing is enableda, the user will be 
prompted for a comment when using 
the partial download feature.

Prompt for audit comment on Partial 
Uploading program from Processor

If auditing is enableda, the user will be 
prompted for a comment when using 
the partial upload feature.

Prompt for audit comment on processor 
name change

If auditing is enableda, the user will be 
prompted for a comment when 
changing the name of a controller.

Prompt for audit comment on program 
file name change

If auditing is enableda, the user will be 
prompted for a comment when 
changing the name of a program file.

Prompt for audit comment on reset of 
diagnostic counters

If auditing is enableda, the user will be 
prompted for a comment when resetting 
diagnostic counters.

Prompt for audit comment on Rung 
Deletion

If auditing is enableda, the user will be 
prompted for a comment when deleting 
a ladder logic rung.

Prompt for audit comment on scanlist 
modified

If auditing is enableda, the user will be 
prompted for a comment when 
modifying a scanlist.

Prompt for audit comment on Storing to 
EEPROM

If auditing is enableda, the user will be 
prompted for a comment when burning 
the EEPROM for a controller.

Prompt for audit comment on Testing 
Pending Edits

If auditing is enableda, the user will be 
prompted for a comment when testing 
pending program edits.

Prompt for audit comment on 
Uploading program from Processor

If auditing is enableda, the user will be 
prompted for a comment when 
uploading from a controller.

Replace The user may use the Replace function.

Save The user may save a project.

Save/Delete User Workspace The user may save or delete user 
workspaces.

This action: If granted to a user:
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Setting security for actions globally
When you configure access rights to securable actions, you can set them for all 
controllers or for individual controllers. This section describes how to set 
security for actions globally.
1. Start the FactoryTalk Administration Console by clicking Start > 

Programs > Rockwell Software > FactoryTalk Administration 
Console. 

2. If you are not automatically logged onto the FactoryTalk Directory 
Server, log onto the server when prompted to do so. You must log onto 
the FactoryTalk Directory using an administrator account (or an account 
that has the rights to change security settings).

3. Once you are logged onto the server, right-click the Networks and 
Devices folder, and then click Security. 

4. The Security Settings for Networks and Devices window appears. In this 
window:
a. Select the user or user group for which you want to configure access 

to secured actions. (If you need to add a user or user group, click the 
Add button.)

b. Open the RSLogix 5 list by clicking the plus sign (+),

Transfer To/From EEPROM The user may burn or read from a 
controller's EEPROM.

Upload The user may upload a project from a 
controller.

View Extended Forces The user may view extended forces.

View User Defined Structures The user may view user defined data 
structures.

Offline Channel Configuration Editing The user may edit the channel 
configuration in offline mode.

Online Channel Configuration Editing The user may edit the channel 
configuration in online mode.

a. To enable auditing, you will need to install the optional source control software for 
RSLogix 5. This software is available from Rockwell Software Technical Support.

This action: If granted to a user:
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c. Check the Allow or Deny boxes for the actions. 

If you need more information about configuring FactoryTalk Security, click the 
Help button on the Security Settings for Networks and Devices window.

Setting security for actions on a controller basis
Normally, controllers inherit their security settings from the settings for the 
Networks and Devices object. However, you can break the inheritance chain 
for a controller, configuring security for that controller separately. In that case, 
the controller no longer inherits its security settings from the Networks and 
Devices object. 
To configure security for a controller so that it does not inherit its settings from 
the Network and Devices object:
1. Start the FactoryTalk Administration Console by clicking Start > 

Programs > Rockwell Software > FactoryTalk Administration 
Console. 

2. If you are not automatically logged onto the FactoryTalk Directory 
Server, log onto the server when prompted to do so. You must log onto 
the FactoryTalk Directory using an administrator account (or an account 
that has the rights to change security settings).

Click the user or group to 
which you want to allow or 

deny access

Check the Allow or Deny
box for the action

Open the RSLogix5 list
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3. Once you are logged onto the server, browse to the controller for which 
you want to configure security for actions (under the Networks and 
Devices object in the Administration Console’s Explorer tree). Right-click 
the controller, and then click Security. 

4. The Security Settings for Networks and Devices window appears. In this 
window:
a. Check the Do not inherit permissions box. The software asks 

whether you want to copy the permissions from the parent object 
(the Networks and Devices object) or remove all inherited 
permissions from the object (the controller). If you have already 
configured security for the Networks and Devices object and want to 
use most of that configuration for the controller, copy the 
permissions. Otherwise, remove the inherited permissions.

a. Select the user or user group for which you want to configure access 
to secured actions. (If you need to add a user or user group, click the 
Add button.)

b. Open the RSLogix 5 list by clicking the plus sign (+),
c. Check the Allow or Deny boxes for the actions.

Click the user or group to 
which you want to allow or 

deny access

Check the Allow or Deny
box for the action

Open the RSLogix5 list

Check the Do not inherit 
permissions box
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Starting RSLogix 5 software 
To start RSLogix 5 software, click Start > Programs > Rockwell Software > 
RSLogix 5 > RSLogix 5.

Troubleshooting installation
If RSLogix 5 does not start up or run properly: 

Do you have the correct version of RSLinx Classic installed? The software 
requires RSLinx Classic version 2.51.00 or later. 
Does your computer have enough memory? Check the hardware 
requirements on the first page of this chapter for memory requirements. 
Is the RSLogix 5 software activated? You will need to activate RSLogix 5 
before you can use it.
Do you have FactoryTalk Security or Security Server support enabled? If so:

If FactoryTalk Security support is enabled, are you disconnected from 
your network and unable to access your FactoryTalk Directory Server? Is 
FactoryTalk Security configured to allow you to have access to RSLogix 5 
functions? Contact your FactoryTalk Security administrator for more 
information.
If Security Server support is enabled, are you disconnected from your 
network and unable to access your Security Server(s)? Is the Security 
Server configured to allow you to have access to RSLogix 5 functions? 
Contact your Security Server administrator for more information.
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Overview of RSLogix 5
RSLogix 5 software is a 32-bit Windows ladder logic programming package for 
the Allen-Bradley PLC-5 family of programmable logic controllers. RSLogix 5 
is compatible with programs created with any of Rockwell Software’s PLC-5 
programming packages. 
RSLogix 5 software includes:

a free-form ladder editor that lets you concentrate on the application logic 
instead of proper syntax as you write your program
a powerful project verifier that you use to build a list of errors you can 
navigate to make corrections at your convenience
drag-and-drop editing to quickly move data table elements from one data file 
to another, rungs from one subroutine or project to another, or instructions 
from rung to rung within a project
search and replace to quickly change occurrences of a particular address or 
symbol
a point-and-click interface (project tree) that lets you access all the folders 
and files contained in your project 
a custom data monitor to view separate data elements together and observe 
interactions
a histogram function to monitor a data table bit or word as either text or a 
graphical timing chart
SFC and Structured text editors, based on IEC 1131-3 standards, that share 
the same simple drag-and-drop editing found in the common ladder logic 
editor
PC5 libraries for storing and retrieving portions of ladder logic for use across 
any of Rockwell Software’s PLC-5 programming software products 

Chapter

2 Getting started with 
RSLogix 5
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Navigating RSLogix 5
RSLogix 5 includes the screen elements described below.

ladder view. In this part of the application window you can view several 
program files at the same time. This is where you edit your ladder logic. 
results window. Displays the results of a Find All search or a verification 
procedure. You can hide this window view or drag it from the application 
window and place it anywhere on your screen. 
menu bar. Select functionality from the menus that appear as you click each 
selection on this bar. 
standard toolbar. The standard toolbar (also referred to as the main toolbar) 
contains many functions that you will use repeatedly as you develop and test 
your logic program. If you want to know what any of the icons represent, 
RSLogix 5 can tell you. Just move your cursor to the icon. A floating tooltip 
window will appear and tell you what the icon is used for. 

Add-in toolbarInstruction toolbar
Menu bar

Standard (Main) 
toolbar

Online bar

Project tree

Results window

Status bar

Ladder view
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online bar. Learn the operational mode and see whether you have online 
edits or forces installed at a glance. You can even view the driver and node 
number. 
instruction toolbar. Displays instruction mnemonics in tabbed categories. 
When you click on a category tab the instruction toolbar just above it 
changes to show that category of instructions. Click an instruction to put it 
in your ladder program. 
add-in toolbar. In RSLogix 5 Professional only. Use this toolbar to quickly 
access add-in software such as RSWire I/O Builder. 
status bar. Look here for ongoing status information or prompts, as you use 
the software. 
project tree. Displays all the folders and files contained in your project. 

If you right-click most items in the tree you will see a menu specific to the 
item selected. For example, if you right-click on a program file, you see 
options to rename, open, hide, or reveal properties of the program file, 
among other things.

This symbol ( - ) means that the folder’s 
contents are already visible. Click the 
symbol to collapse the folder and hide its 
contents.

This symbol ( + ) means that the 
folder’s contents are not visible. Click 
the symbol to expand the folder and 
reveal its contents.
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Opening multiple program files 
To open a program file, simply double-click the file in the project tree. To open 
additional files, double-click each file that you want to open in the project tree. 
A tab for each open program file appears at the bottom of the ladder view. 

Splitting the viewing window
To open multiple files within the same project, you can split the viewing 
window. 
1. Position the cursor on the split bar in the ladder view window. The 

pointer turns into a double bar with two arrows. 

2. Click and drag the split bar down to show two different viewing panes of 
the program file.

3. With focus in either pane, double-click the program file in the project tree 
that you want to view. The second file is opened on a tab in that pane. 
Viewing two program files at once in this way makes drag and drop 
between them easier. You can also display different sections of the same 
file in each pane to facilitate moving or copying items within the same file. 

Opening multiple program windows
Another method of viewing multiple program files is to open a separate 
window for each.
1. In the project tree right-click on the program file you want to open. 
2. Select New Window. 
3. Repeat this process for any additional program files you wish to view 

simultaneously.
To close a program window, click its close button. 

Click a tab to view the file. 
To close a file, right-click its 
tab and select Remove.

Split bar
Cursor
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You cannot view program files from different projects with only a single 
instance of the RSLogix 5 application software running on your computer. You 
must open more than one instance of RSLogix 5 to work on multiple projects 
at the same time. Once you have the projects opened, however, you can drag 
and drop instructions and data between them. 

Quick Start steps for development 
The following steps explain how to get up and programming quickly with 
RSLogix 5 as soon as you install it. 

Step 1 • Configure a driver in RSLinx Classic
A “light” version of

RSLinx Classic, called
“RSLinx Classic Lite”

comes with RSLogix 5.
This version of RSLinx

Classic provides the
communication drivers

necessary to use
RSLogix 5. RSLinx

Classic Lite will not,
however, provide
communications

through DDE or OPC –
those communication
modes are used with

other software
packages, such as HMI

or data acquisition
packages. To use DDE

or OPC
communication, you

will need to purchase
RSLinx Classic.

Of course, you will want your program to run in a controller. That means you 
will need some way to connect your computer to your controller – and you will 
have to tell the software how you are connected. 
Communications from RSLogix 5 take place through another software 
package, called RSLinx Classic. RSLogix 5 talks to RSLinx Classic, which in 
turn talks to your communications devices. 
A driver is a small piece of software that allows a computer to talk to other 
systems. In this case, RSLinx Classic uses drivers to connect your computer to 
your processor. You have to tell RSLinx Classic what driver you want to use to 
make that connection.
The driver you use depends on the way your processor is physically connected 
to your computer. There is a wide variety of possible physical connections; it’s 
important you know which type of connection your system is using and how 
that physical connection is configured. For instance, if your processor is 
connected to your network through another computer running RSLinx Classic 
Gateway, you need to use an RSLinx Classic Gateway driver. If you are directly 
connected to your processor through a 1784-KT card, you need to use the 
driver for that card. 
You will also need to know the parameters of the physical connections – for 
instance, if you are connecting through a 1784-KT card, you will need to know 
how your KT card is configured and the station numbers of the processors on 
your DH+ network.
To configure a driver in RSLinx Classic:
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d. Open RSLinx Classic by clicking Start > Programs > Rockwell 
Software > RSLinx > RSLinx. RSLinx Classic starts in a minimized 
mode – you will see an RSLinx icon in your Windows System Tray. 
(The System Tray is a part of the Windows Taskbar – by default, the 
System Tray is in the lower right-hand corner of your screen.) Click 
the RSLinx icon to open the RSLinx window.

e. In RSLinx Classic, click Communications > Configure Drivers. 
This opens the Configure Drivers window.

f. In the Configure Drivers window, select the driver you need to use 
based on your physical connection to the processor. For example, if 
you are connecting with a 1784-KT card, select the 1784-
KT/KTX(D)/PKTX(D)/PCMK for DH+/DH-485 devices driver.

g. Click Add New to add the driver to the Configured Drivers list.
h. RSLinx Classic asks you to name the driver. RSLinx Classic uses this 

name to refer to the driver. You can use the default name, or enter a 
name (names can be up to 15 characters long). Click OK.

This is the RSLinx icon
that appears in the

System Tray

Click the down arrow to select a 
driver from the Available Driver 
Types list

Click Add New to add 
the driver
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i. The window that appears next depends on the driver you selected. 
This window is where you configure the driver. Configure the driver 
to match your physical connection to the processor. If you need help 
with the parameters for the driver, click the Help button on the 
window.

j. When you have finished configuring the driver, the driver appears in 
the Configured Drivers list of the Configure Drivers window. Click 
Close.

k. You need to make sure the communications driver you configured is 
working properly. To do this, use the RSWho function in RSLinx 
Classic. This function shows what processors and other 
communications devices are available through the driver. To display 
an RSWho window, click Communications > RSWho. 

l. In the RSWho tree, open the driver you configured. You should see 
the processor to which you want to connect. If you can see the 
processor, the driver is configured correctly and you can proceed to 
the next step. 
If you cannot see the processor, the driver is not configured correctly 
(or some other communication problem is preventing you from 
accessing the processor). Correct the problem before proceeding. See 
the online help in RSLinx Classic for information about the driver you 
are using.

Step 2 • Configure system communications
There are two kinds of communications configuration in RSLogix 5. 

System communications, which are set globally. When you set system 
communications parameters, those parameters are the default for all new 
projects in RSLogix 5. 

In the RSWho
tree, open the

driver you
configured (a

Remote Devices
via Linx Gateway

driver is shown
here)
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Controller communications, which are communications parameters 
specific to a given project. When you set controller communications for a 
project, those settings overwrite the system communications settings for that 
project. (Other new projects still use the system communications settings.)

Setting system communications parameters can save you time later. We suggest 
you set the system communications parameters before creating your first 
project in RSLogix 5.
To set the system communications parameters:

a. From the Comms menu, click System Comms. This displays the 
Communications window. (If RSLinx Classic is not running, it will 
start.) The Communications window is very much like the RSWho 
window you encountered while configuring your communications 
driver. 

b. In the Communications window tree, open the driver you configured. 
The processor you want to program should be visible. Click the 
processor, then click OK.

Open the driver you
configured

Click the processor you
want to program, then

click OK
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There is a great deal more that you can do from the Communications window. 
See the online help for more information.

Step 3 • Create a new project or open an existing 
project

RSLogix 5 is based on projects. A project is the complete set of files associated 
with your program logic. 

New Project 
To create a new project:
1. Select File > New.
2. Provide information about your processor on the Select Processor Type 

dialog. If you already set up communications as in Quick Start Step 1, this 
information appears on the dialog. If not, specify the communications 
settings here. Click OK.

RSLogix 5 creates and displays the project tree control for your new project. 
This project tree is your access point to program, data table, and database files. 
See page 31 for more information about the project tree.

Existing Project 
To open an existing project:
1. Select File > Open.
2. Click the file you want to open and click Open. If the file you want to 

open does not appear on the list:
Use the Look in list to navigate to a different folder.
Use the Files of type list to display files with an extension other than 
.RSP, .X5, .PC5, or .AF5.

Tip If you want to change the system communications settings, click 
Comms > System Comms.
If you want to set different communications parameters for a given 
project but leave the system communications settings alone, open 
the properties for the project’s controller. See the online help for 
RSLogix 5 for more information.
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RSLogix 5 can open projects and documentation files that were developed 
using any Rockwell Software DOS-based (PLC-5 A.I. Series or 6200 Series 
PLC-5) or Windows-based (RSLogix 5 or WINtelligent Logic 5) programming 
software. If you experience a problem however, there are special considerations 
that may affect retrieval of your database files. For more information about 
opening projects created using other Rockwell Software PLC-5 programming 
software products, refer to Chapter 3, Opening A.I. and 6200 project files in 
RSLogix 5 on page 49. 

Step 4 • Add the chassis and I/O 
To add a chassis:
1. From the Controller folder in the project tree, double-click the IO 

Configuration icon. The I/O Configuration - Chassis Table dialog 
appears.

2. Right-click inside the I/O Configuration dialog and select Add Chassis. 
The Edit Chassis Properties dialog box appears, with the Chassis tab 
selected.

3. Select the chassis type by clicking one of the option buttons. A list is 
displayed showing the available chassis.

4. Select the desired chassis from the list.
5. If you’ve selected a Flex I/O chassis, enter the number of slots in the 

Number of slots field. Enter a value from 1 to 8.
6. Document the DIP switch settings by selecting the configuration settings 

in the pull-down list boxes in the DIP Switches section of the dialog box.
7. Click OK to accept your choices and close the dialog box. 

Tip For clarification of the different file types and their extensions, click 
the Help button on the Open/Import PLC5 Program dialog.
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Some modules may require configuration after they have been added. See 
Chapter 4, Hardware configuration on page 53 for more information about 
hardware configuration. 

ControlNet users: For ControlNet™ processors controlling I/O via 
ControlNet, the chassis and modules must first be mapped in RSNetWorx™ 
before they will appear in the chassis table to be configured. Also, the 
associated .XC file (created by RSNetWorx) and the ControlNet node number 
of the processor must be entered in Controller Properties in the Project Tree. 

Step 5 • Create program and data table files 
The project tree is your point-of-entry for creating new files or accessing 
existing files. To create a new file, right-click the program or data file icon and 
then select New. A dialog appears for you to provide information about the 
file. For more information, refer to the online help. 

A program file may contain controller information (SYS 0), the main ladder 
program (LAD 2), or a subroutine program. 
Data table files contain the status information associated with external I/O and 
all other instructions you use in your main and subroutine ladder program files. 
In addition, these files store information concerning controller operation. You 
can also use data table files to store look-up tables if needed.

By default the first 
chassis listed in a 
new project is the 
1771-A1B four slot. 
You can change this 
by right-clicking on 
the chassis and 
selecting Properties.

To add modules to the chassis, right-click the 
chassis and select Display Chassis. The 
smaller dialog shown here appears.

On the Chassis dialog, right-click in the cell for the 
slot to which you wish to add a module and select 
Insert Module.

Right-click and select New 
to create a new program or 
data file.

Data files are also created 
automatically as you assign 
new addresses in your ladder 
program. 
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Step 6 • Enter a logic program
When you open a program file by double-clicking its icon in the project tree, 
the ladder file opens in the right half of the RSLogix 5 window. Usually 
program file #2, the main program file, is opened when you open a project. If 
you have not begun to enter any ladder logic, only the end rung will show. 
To enter ladder logic to a new program:
1. Click on the end rung and then select the new rung icon on the User tab 

of the instruction toolbar. 
2. To place an instruction on a rung, click its icon on the instruction toolbar. 

You can place several instructions on a rung in sequence by clicking the 
icons one after another. RSLogix 5 places instructions from left to right.

3. Assign an address to each instruction. Double-click an instruction, type 
the address in the empty field that appears above the instruction, then 
press the Enter key. With RSLogix 5 you can also drag and drop addresses 
from a data table file onto instructions in your ladder logic.

4. Continue adding rungs, remembering to save your file periodically with 
File > Save.

RSLogix 5 supports a file-based editor. This means that you can:
create and/or edit multiple rungs at a time
enter addresses before you actually create data table files for your I/O
enter symbols before you have assigned addresses for them in the database
enter instructions without having to provide addresses until just before file 
validation occurs

For more detailed information about entering ladder logic including 
information about shortcuts, branching, addressing, and performing program 
edits online, refer to Chapter 6, More about entering ladder logic on page 67.

New Rung 
icon

If there are too many instructions on the toolbar 
to see all at once, use these arrows to scroll.

Each of these tabs displays 
a different category of 
instructions in the toolbar.

Use these arrows 
to scroll through 
the tabs.
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Step 7 • Add documentation to your logic 
instructions 

You can use several methods to add symbols and descriptions to addresses in 
the database. 

Add a symbol directly to an addressed instruction in the ladder logic. 
Double-click the address, type the symbol in the address edit field, and press 
the Enter key. 
You can enter a symbol in this manner before an address has been assigned, 
then later use the database editor to assign an address. (Database editor is an 
encompassing term for the various database editing dialogs that appear when 
you click one of the icons under Database in the project tree.) 
Right-click an instruction address or rung number in the ladder logic and 
select Edit Symbol or Edit Description for an address or Edit Comment 
or Edit Title for a rung.
Modify an address's symbol and description in the data file. Double-click the 
data file in the project tree, click on an address in the table. The bottom of 
the dialog contains fields where you can enter the documentation for the 
address.
Modify (add, delete, change) the database using the database editor. This is 
the preferred method for deleting project documentation. All 
documentation (including instruction comments and group names and 
descriptions) can be edited with this method. Double-click an icon in the 
database folder located in the project tree. Another method of accessing the 
database editor is to right-click an address in the ladder logic and select Goto 
DataBase. 
Copy symbols and descriptions from the ladder display between RSLogix 5 
and RSLogix 500 or between instances of RSLogix 5 by using cut, copy, and 
paste options or by dragging and dropping the symbol or description from 
one application to another. (A dialog will appear if there is a database 
collision.) Any errors or inconsistencies between data types will be flagged 
when the program is verified. You cannot copy and paste to other 
applications within the database editor, only from within the ladder view. 
Use Microsoft Excel to edit the database. Select Tools > Database > Edit 
Using Excel. (This feature is available only in RSLogix 5 Professional.)

For information about database import and export options refer to Chapter 5, 
Importing or exporting the documentation database on page 59.
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Step 8 • Verify the program logic 
When you are ready to build your project, you can validate a single program file 
or you can validate your entire project. Select Edit > Verify File or Verify 
Project. 
After you initiate a verification, the Verify Results output window displays and 
gives you information about mistakes or omissions that may have occurred as 
you wrote your program logic. 

Step 9 • Configure the communication channels
Enhanced (New Platform), Protected (Secure), Ethernet, and ControlNet 
PLC-5 processors have communication channels that must be configured. (For 
Soft Controllers, configure the PLC-5 I/O, Remote I/O scan list, and SLC 500 
I/O. Double-click the appropriate icons under IO Configuration in the project 
tree.)
To configure communication channels:
1. Double-click the Channel Configuration icon in the Controller folder in 

the Project tree. 

Double-click an error 
message to go directly 
to the relevant location 
in the code.

To hide this window 
when finished, select 
View > Results.
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2. Edit the properties on the dialog and click OK. 

Step 10 • Download and go online 

To download and go online:
1. Select Comms > Download to download the current offline program 

into the controller. 
2. RSLogix 5 automatically verifies the project. If no errors are found, the 

download continues. If errors are found, you must correct them and 
initiate the download again (with Comms > Download). 

3. After downloading, RSLogix5 will ask if you want to go online. Click Yes 
to go online.

Use the Channel 0 tab 
to configure settings 
for RS232/422/423.

Use the Channel 1A - 2B 
tabs for DH+, Scanner, 
Adapter, or Inactive I/O 
channel mode.

Use the Channel 2 tab 
(not shown) for Ethernet 
or Local I/O Extension 
channels.

Use the Channel 3A tab (not shown) when 
using a VME or Ethernet sidecar coprocessor.

For more information about the parameters on 
the dialog, click the Help button or press F1.

Tip If you are developing the program offline, for example on a laptop 
remote from the site, and later plan to download and run the 
program on a specific processor (node) via a determined protocol, 
you may want to override system communication settings made in 
Step 2 • Configure system communications on page 35. Double-click 
Controller Properties in the project tree, click the Controller 
Communications tab, and set the communication settings. Settings 
made on this dialog will override any driver and node settings 
established in Step 2, and should be completed before performing 
this step. 

Cick here to change the 
processor mode or go 
offline.
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If you want to download only specific program and data files, force data, or 
channel configuration data, select Comms > Partial Download. This allows 
you to maintain certain parts of your PLC-5 program, while overwriting other 
parts.

Step 11 • Monitor data files 
You can use RSLogix 5 to watch what is happening in your data table files. This 
procedure is called monitoring data table files.
When you are monitoring data table files, you can:

define how your data file selection grid will display
change values in the data table
change the display radix
show which addresses are used in your ladder logic
switch between files
quickly jump to another address in another data table file 
cross reference data

To monitor data, simply open a data file (double-click it) in the project tree. 
You can have multiple data table files opened for monitoring at the same time. 
To cascade or tile all the windows opened in your RSLogix project, select an 
option from Window > Arrange.
Data changes made offline only affect the disk file unless the program is 
restored to the processor. 
Data changes made online only affect the processor file unless the program is 
saved or uploaded while online to update the disk file. 
For information about how you can perform a cross reference, force I/O, or 
create and monitor lists of related addresses instead of accessing the data table 
files, refer to Chapter 7, More about monitoring data on page 79. Also, you can use 
histograms to monitor a data table bit or word as either text or a graphical 
timing chart. More information about histograms can be also be found in 
Chapter 7.

Step 12 • Search and replace instructions
The Find option allows you to quickly locate instructions, addresses, and 
symbols in ladder program files. You can even search for edit zones within your 
logic program. If you want to automatically replace instructions and addresses 
with different ones, you can use the Replace option. You can use wildcards in 
your find and replace operations. 
To search (and replace):
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1. Select Search > Find or Search > Replace.
2. Specify the instruction you want to locate in the Find What field. You can 

type any of the following:
the mnemonic (such as XIC or TON)
the address (such as B3/4)
a combination of both mnemonic and address (XIC B3/4)
a combination of mnemonic and symbol (XIC REPEAT) 

3. If replacing, type what you want the instruction replaced with in the 
Replace With field.

4. Set remaining parameters on the dialog if desired (such as the search 
direction) and click Find Next or Replace. For more information about 
the options and buttons on the dialog, click Help.

Step 13 • Print a report
You can obtain a printout of various elements of your project, such as program 
files, data table files, and processor information. 
To print a report:
1. Select File > Report Options. The Report Options dialog displays a tree 

on the left with the elements of a report that you can configure (such as, 
which program files to print, title, header, fonts, colors, etc.). The right 
side of dialog displays the controls for you to set.

2. Use the checkboxes to mark everything you want included in the report.
3. Click Page Setup to set the paper size, margins, and orientation.
4. In the tree, click an element to configure that element’s settings. For 

example, when you click Program Files in the tree, the options on the 
dialog allow you to select which program files you would like to print and 
even ranges of rungs. 
If you are including a title page, header, and footer, be sure to click each of 
these elements in the tree to set them up.

An alternative method for 
searching is to click inside this 
box and type the numeric or 
symbolic address or the 
instruction mnemonic you want 
searched.

This is a tooltip. To see the function of an item 
on the toolbar, point to it without clicking.
Getting started with RSLogix 5   •  45



5. Click Print Preview to see how the report will appear. You can scale up 
the image to make the information appear larger on the printed page or 
scale down the image so that, in cases where many instructions are on a 
rung of logic, all the instructions can fit on the printed page. 

6. If the report appears as you expected, click Print to print the report. 
Otherwise, click Options to return to the Report Options dialog and 
make changes.
If you wish to save report settings for future use, click Save/Load at the 
bottom of the Report Options dialog. Notice that the Report Options 
Setup Load/Save dialog that appears has an Import and an Export button 
allowing you to import and export report formats for use with other 
projects.

Quick Start steps for maintenance 
The steps below will help you get online quickly for maintenance tasks, like, for 
example, changing some contacts. 

Step 1 • Establish communications with the 
processor

This step assumes that a driver has been configured in RSLinx Classic or 
RSLinx Classic Lite. If not, do so before performing this step. Refer to the 
online help in RSLinx Classic for more information on configuring drivers. 
(Select driver configuration in the RSLinx Classic help index).
1. Select Comms> Who Active Go Online.
2. Use the tree structure in the left pane to navigate to the network on which 

the processor resides. 
3. Click the processor in the right pane to select it.

Step 2 • Go online
1. Click the Online button.
2. The system checks for a project on your computer that matches the 

processor program. One of three things will happen:

Tip RSLogix 5 now provides a feature for going online more quickly 
called Online Now. System communications must be configured. 
Select Comms > Online Now. If the offline program file is 
different from that in the processor, the processor file is uploaded 
automatically. The database is not loaded and x-ref is disabled. More 
information is available in the online help.
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A perfect match is found. In this case, RSLogix 5 goes online with no 
further action required on your part.
An imperfect match is found for one or more projects with the target 
processor name. In this case, select the desired project file from the list 
and click the Upload Logic, Merge with Existing File’s 
Comment/Symbol DB button.
No match is found. In this case, click the Create New File button.
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Introduction
RSLogix 5 can open projects and documentation files that were developed 
using any RSI DOS-based (PLC-5 A.I. Series or 6200 Series PLC-5) or 
Windows-based (RSLogix 5 or WINtelligent Logic 5) programming software. 
If you experience a problem however, there are special considerations that may 
affect retrieval of your database files. 

Opening a Project File 
If the procedure below does not satisfactorily open the ladder logic file and its 
accompanying database files, read and follow the special considerations for 
PLC-5 A.I. Series software and 6200 Series PLC-5 programming software 
discussed in this chapter.
1. Select File > Open.
2. Use the Look In box to navigate to the location of the project file.
3. In the Files of Type field, select the type of project. RSLogix 5 supports 

.RSP, .X5, .AF5 and .PC5 library files, as well as backup files.
4. Click the project file you want to open, and click Open. 

Chapter

3 Opening A.I. and 6200 
project files in 
RSLogix 5
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Special Considerations

Retrieve the PLC-5 A.I. Series documentation 
database
When you open an X5 project created using PLC-5 A.I. Series programming 
software, RSLogix 5 automatically imports the documentation database making 
it available to the X5 file. If however, for some reason, the documentation 
database cannot be accessed or fails to accompany the project, you can attach 
the documentation using the method below. 
Make sure your have followed the procedure above for opening a project 
before proceeding with the following steps.
1. With the project opened, select Tools > Database > Native Import.
2. Select AI for the Import input format.
3. Select which types of data to import and specify what to do in case of 

collisions with existing data records. Press the F1 key if you need help on 
the dialog.

4. Click OK.
5. Find the .DSC file for your project; click it to select it.
6. Click Open. The data you specified will be imported into the current 

project.

Open a 6200 Series PLC-5 Project
When you attempt to open an AF5 project created using DOS-based 6200 
Series PLC-5 programming software, RSLogix 5 does two things. It 
automatically launches an internal conversion utility that converts the AF5 file 
into an X5-format file. Then it imports the documentation database making it 
available to the X5 file. 
Sometimes, due to the complexity of your project or the software version used 
to create it, you may experience a problem with this process. You may find that 
RSLogix 5:

cannot retrieve the database documentation associated with the file (corrupt 
database message)
has problems opening the AF5 project file

If this happens follow the procedure below to open the 6200 Series PLC-5 
project file including the documentation database.
1. Using the 6200 Series DOS programming software, save the 6200 Series 

PLC-5 project file as an X5 file.
2. In RSLogix 5, select File > Open.
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3. Use the Look In box to navigate to the location of the project file.
4. In the Files of Type field, select PLC5 Programs(*.X5). 
5. Click the project file you want to open, and click Open. (The 

documentation will not follow. It must be imported as described next.)
6. Select Tools > Database > Native Import. 
7. Select AB 6200 for the Import input format.
8. Make sure Import ALL is selected.
9. Click OK.
10. Use the Look in box to navigate to the location of the 6200 Series PLC-5 

database files (OP$ extension). Click the database file, then click Open. 
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Introduction 
This chapter provides information on configuring your chassis and I/O 
modules in RSLogix 5.

The chassis table 
The chassis table is the starting point for adding, deleting, or configuring 
chassis, processors, adapters and I/O modules. To display this window double-
click the I/O Configuration icon in the project tree.

Use the right mouse button menus to perform tasks in the Chassis Table. 
The chassis table contains information about the current configuration of your 
I/O chassis, including:

the chassis type
the processor (or adapter) for the chassis
whether the chassis is inhibited or reset
the rack addressing mode for the chassis
the rack, group, and slots encompassed by the chassis
whether the chassis is set to use complementary I/O

For clarity, you can limit your view of the chassis table to only show rows 
having directly to do with I/O—that is, the chassis and I/O scanner rows. To 
do this, clear the Show Non-I/O Rows checkbox at the top of the chassis 
table.
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Adding and configuring a chassis
By default each processor in your project is associated with one I/O chassis. 
You can add additional chassis to a processor to expand the number of I/O 
modules that processor can address. Adding a chassis consists of selecting the 
type of chassis you are using for your project and documenting the chassis DIP 
switch settings. 
ControlNet users: For ControlNet™ channels, first use RSNetworx™ to 
insert, delete and modify chassis and modules. Then use RSLogix 5 to 
configure the modules.
To add and configure a chassis:
1. From the Controller folder in the Project tree, double-click the I/O 

Configuration icon. The I/O Configuration - Chassis Table dialog 
appears. 

2. Right-click in the Chassis Table and select Add Chassis. The Edit Chassis 
Properties dialog box appears, with the Chassis tab selected.

3. Select the chassis type by clicking one of the option buttons. A list is 
displayed showing the available chassis.

4. Select the desired chassis from the list.
5. If you’ve selected a Flex I/O chassis, enter the number of slots in the 

Number of slots field. Enter a value from 1 to 8.
6. Document the DIP switch settings by selecting the configuration settings 

in the pull-down list boxes in the DIP Switches section of the dialog box.
7. Click Apply to accept your choices and leave the dialog box open or click 

OK to accept your choices and close the dialog box. 

To change or redefine a 
chassis, right-click on it and 
select Properties.

To stop an I/O 
chassis from being 
scanned, check Inh.

To reset scanning of 
all I/O in the chassis, 
check Res.
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Configuring a PLC or I/O adapter
Each I/O chassis has an I/O adapter. The adapter is either a PLC-5 processor, 
configured when you begin a project, or an I/O adapter. Select chassis DIP 
switch settings, add or change the type of adapter, or establish configuration 
settings for the adapter in any chassis by double-clicking on the processor or 
adapter in the Chassis Table (or right-clicking and selecting Properties). 

For a PLC-5:

For an I/O adapter:

Indicate the dip switch 
settings of the chassis.

Select the I/O adapter 
type from this llist.

Make your selections for 
the scanner PLC and 
scanner channel here.

Indicate the dip switch 
settings of the chassis
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Adding I/O modules 
To add a module to a chassis: 
1. Double-click the I/O Configuration icon in the project tree to open the 

Chassis table.

Using the method above, you can add, delete, or edit modules as well as create 
descriptions for each one. Some modules require configuration after they are 
added. 
Remember that you can always press [F1] for help about any task you are 
attempting as you progress through the dialogs while you use RSLogix 5.

2. Right-click the 
chassis and select 
Display Chassis.

4. Select the module 
type and the specific 
module. Click OK.

3. Right-click the cell for 
the slot you wish to add 
a module to and select 
Insert Module.
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Configuring I/O
To configure an I/O module:
1. Double-click the IO Configuration icon in the project tree. 
2. Right-click the chassis containing the module you want to configure and 

select Display Chassis. 
3. Right-click the module that you want to configure and select Display 

Module. The module configuration window varies from module to 
module and configuration is different for discrete and analog modules. 
Press [F1] to display help on that particular module. 

Discrete. These modules require no configuration, but symbols, 
descriptions, values, and forcing can be assigned to individual I/O 
points. Click Close when finished editing. 
Analog. Most analog modules require configuration. These configurable 
analog I/O modules are known as “intelligent block-transfer” modules. 
In addition to defining block transfer read/write pairs, configuration 
parameters must be defined, such as scaling, alarm limits, or other types 
of items particular to the specific type of module. 
The first time you edit a particular analog I/O module, the Enter 
Module Addresses dialog appears. Enter addresses or click Auto-Pick 
to have RSLogix 5 automatically select the addresses required for the 
module, and then click Done. (Auto-Pick is not available for 
ControlNet modules.) That module’s configuration window appears. 
Make your changes, click Accept Edits, then click Close.
If you want to edit addresses in the future, right-click in the spreadsheet 
portion of the module’s configuration dialog and select Edit Variable 
Addresses.

Tip Most analog modules require block transfer rungs. RSLogix 5 can 
automatically generate these rungs for you. On that module’s 
configuration dialog, click the Insert Ladder Rungs button.
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Introduction 
The import and export utilities are available from the Tools menu by clicking 
Database. Use the import functionality in RSLogix 5 when you want to apply 
documentation that already exists to a project you are currently developing in 
RSLogix 5. Use the export functionality in RSLogix 5 to make the database 
documentation that is part of your current RSLogix 5 project available to other 
projects. 

Import database 
You can apply documentation to newly created logic files by importing existing 
database documentation. The existing documentation might come from:

projects developed using Rockwell Software’s DOS-based PLC-5 A.I. Series 
or 6200 Series programming software
another project developed using RSLogix 5
a spreadsheet application, like Microsoft Excel™ (saved as a .CSV file)
an ASCII text file

Sometimes when you import a documentation database, there may be 
conflicting entries in the import file and the database. This is called a collision. 
Before you begin any import you can select if you want the imported database 
instance or the current database instance discarded if collisions occur. 

PLC-5 A.I. Series project documentation database
To import a PLC-5 A.I. Series database: 
1. Select Tools > Database > Native Import.
2. Click AI.
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3. Select which database components to import.
address symbols and descriptions (.DSC files) 
page titles and rung descriptions (.RPD files) 

4. Select an option for handling collisions and click OK.
5. Locate and select the database file you want to import and click Open.
If you have a database that was exported from PLC-5 A.I. Series software, you 
may need to follow the instructions for importing a CSV or ASCII file, 
depending on what selections were made when exporting from A.I. If exported 
in .CSV, then follow the instructions for importing a .CSV file on page 61. If 
exported in .EAS format, follow the instructions for importing an ASCII file 
on page 61.

6200 Series PLC-5 project documentation 
database
To import a 6200 Series database:
1. Select Tools > Database > Native Import.
2. Click AB 6200.
3. Select which database components to import.

address symbols and descriptions 
instruction comments 
page titles and rung descriptions 

4. Select an option for handling collisions and click OK.
5. Locate and select the database file you want to import and click Open.

By default the file type selected for import is .OP$. The .OP$ file is the 
database control file. It references individual database files (for example the 
symbol/description file or the page title/rung description file) that reside 
in the same folder as the .OP$ file. After an import completes, RSLogix 5 
creates a log file that informs you which database files successfully 
imported and which database files contained errors and could not 
successfully be imported. 

RSLogix 5 documentation database
To import an RSLogix 5 database:
1. Select Tools > Database > Native Import.
2. Click RSLogix 5.
3. Select which database components to import.

address symbols and descriptions 
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instruction comments 
page titles and rung descriptions 
symbol groups

4. Select an option for handling collisions and click OK.
5. Locate and select the database file you want to import and click Open.

By default the file type selected for import is .CTD. The .CTD file is the 
database control file. It references individual database files (for example the 
symbol/description file or the page title/rung description file) that reside 
in the same folder as the .CTD file. After an import completes, RSLogix 5 
creates a log file that informs you which database files successfully 
imported and which database files contained errors and could not 
successfully be imported. For a complete list of RSLogix 5 file extensions 
for individual database documentation refer to the online help and search 
“file extensions.” 

CSV (Comma Separated Values) file 
You may wish to import files created with a spreadsheet application such as 
Microsoft Excel or files exported from PLC-5 A.I. Series software in .CSV 
format.
To import a CSV file:
1. Select Tools > Database > ASCII Import.
2. Click CSV.
3. Select which database components to import.

address symbols and descriptions 
instruction comments 
symbol groups

4. Select an option for handling collisions and click OK.
5. Locate and select the database file you want to import and click Open.
For an example of a .CSV file, refer to the online help and search the index for 
“CSV format for database import/export.”

ASCII delimited text file
You can import documentation files that were created using RSLogix 5 
software or PLC-5 A.I. Series software and exported and saved as ASCII 
delimited files (.EAS in A.I.). ASCII delimited means that the fields for each 
RSLogix 5 database record are enclosed in quote marks and separated by 
commas. 
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To import an ASCII database file:
1. Select Tools > Database > ASCII Import.
2. Click RSLogix 5.
3. Select which database components to import.

address symbols and descriptions (.EAS files) 
instruction comments (.EIC files) 
page titles and rung descriptions (.ERP files) 
symbol groups (.ESG files) 

4. Select an option for handling collisions and click OK.
5. Locate and select the database file you want to import and click Open.

Any file extension may be used for an ASCII delimited text file. You can 
look for and select any file extension, not just those listed above.

An example of each of the above files, with an explanation of the data fields 
contained within the file, can be found under RSLogix 5 ASCII delimited text file 
examples beginning on page 63.

Export database
Use the export functionality in RSLogix 5 to make the database documentation 
that is part of your current RSLogix 5 project available to other projects. 
To export a database:
1. Select Tools > Database > ASCII Export.
2. Click the tab for the desired output format: RSLogix 5, A.I., AB 6200, or 

CSV (comma separated value).
3. Select which database components to export and specify the filename(s). 

Click Help for more information about any of the options on the dialog.
4. When exporting the documentation database to A.I. or AB 6200 formats 

the symbols, descriptions, and instruction comments may be truncated 
due to size restrictions imposed by the PLC-5 A.I. and 6200 Series 
databases. This may result in conflicts in the exported data. So, unless you 
have accounted for differences between description lengths in RSLogix 5 
and PLC-5 A.I. Series programming software and planned your 
description text accordingly, select Treat Source Description as 1 80-
character line. 

After it has been exported, you can edit the ASCII file with a text editor, or load 
the file into another database.
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RSLogix 5 ASCII delimited text file examples 
The examples in this section show how the documentation would be 
represented in an exported ASCII text file using the RSLogix 5 output format. 
Each field in a line of ASCII text is enclosed by quotes and separated by a 
comma. Empty fields are represented with quotes with nothing between them. 

Address symbols and descriptions (.EAS files)
"B3/0","0","SYMBOL","description","","","","","0","","","0","GROUP_NAME"

Page title and rung descriptions (.ERP files)
"RUNG000002-000002","page title","rung comment\"

ASCII Field # Maximum Length Contents

1 39 characters Address

2 N/A Scope (0=global, 2-255=local program file 
number

3 20 characters Symbol

4 20 characters Description line 1

5 20 characters Description line 2

6 20 characters Description line 3

7 20 characters Description line 4

8 20 characters Description line 5

9 12 characters Device code (always 0 for addresses that are 
not real I/O)

10 9 characters Device description above

11 9 characters Device description below

12 N/A Disable cross-reference flag (0=enabled, 
1=disabled)

13 20 characters Symbol group name

ASCII Field # Maximum Length Contents

1 39 characters Data table address or rung identifier

2 80 characters Page title

3 64K Rung description
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Instruction comments (.EIC files)
"B3/0","XIC","instruction comment","","","",""

Symbol groups (.ESG files)
"GROUP_NAME","description"

A.I. ASCII delimited text file examples
These examples show how a line might appear in an ASCII text file exported 
using the A.I. output format. Each field in a line of ASCII text is enclosed by 
quotes and separated by a comma.

Address symbols and descriptions (.EAS files)
"B3/0","0","SYMBOL","description","","","","","0","","","0"

The field breakdown of A.I. ASCII delimited text is the same as shown for 
RSLogix 5 ASCII output format, except the symbol and description fields are 
limited to 15 characters and there is no symbol group field.

Page title and rung descriptions (.ERP files)
"RUNG002-0002","page title","rung comment\"

The field breakdown of A.I. ASCII delimited text is the same as shown for 
RSLogix 5 ASCII output format.

ASCII Field # Maximum Length Contents

1 39 characters Address

2 3 characters Instruction type

3 20 characters Comment line 1

4 20 characters Comment line 2

5 20 characters Comment line 3

6 20 characters Comment line 4

7 20 characters Comment line 5

ASCII Field # Maximum Length Contents

1 20 characters Symbol group name

2 80 characters Symbol group description
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AB 6200 ASCII delimited text file
AB 6200 documentation database files saved to ASCII text format contain 
keywords. Keywords tell the software whether the information immediately 
following the keyword is a rung comment, an instruction comment, an address 
comment, or a symbol. Some examples are shown below. 
SYM B3/0 SYMBOL
SYM O:17/03 UPLOAD
AC B3/0 “description”
AC I:21/03 “AIR STOP CLOSED LIMIT SWITCH\”
IC XIC N7:10/0 “Surge Tank High Level Alarm”
RC CTD C5:0 ” (carriage return)
This is an example of a rung comment with quotation\ marks
and carriage returns at the beginning and end.
” (carriage return)

Key Words
The key words used in AB 6200 documentation database files are:
SYM – symbol
AC – address comment (description)
IC – instruction comment
RC – rung comment
FCN – SFC name
FCI – SFC comment
IOS – I/O module symbol
IOA – I/O module address comment
IOC – I/O module configuration information

CSV (Comma Separated Values) format
Search “CSV format for database import/export” in the RSLogix 5 online help 
index for complete details.
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Introduction
This chapter provides information that you can use to make editing your ladder 
logic easier. 

Backing up your work 
Remember to back up your work as you develop your ladder logic programs. 
RSLogix 5 uses two types of backup functions that you can access at any time, 
and provides you with an auto-recovery file in the case of a power failure. All 
of these files contain the entire description database associated with the project.

Auto-Backup files are created automatically each time you save a project. To 
preset how many backups should be retained for any project, select Tools > 
Options and click the Preferences tab. Enter a number in the Number of 
Backups field. 
Auto-backup files (saved as .RSP files) have the letters BAK and a series of 
numbers (000 to 999) appended to the filename. For example, an auto-
backup created for project TEST.RSP might be identified as 
TEST_BAK000.RSP, and a more recent backup might be identified as 
TEST_BAK001.RSP. 

Chapter

6 More about entering 
ladder logic

Tip Shortcut methods exist for most editing functions within RSLogix 5. 
A list of hot keys (keyboard shortcuts) that enable you to maneuver 
the software without a mouse can be found in a help file that you can 
print out. To access this file click the Help folder in the project tree, 
and then double click on Using the Keyboard. 
A.I Series dot commands are now supported by RSLogix 5. To 
access A.I. Command Portal Emulation, press [Alt .]. Type the 
letters of the dot command (such as EI to insert a rung) and press 
[Enter]. For more information see Dot commands on page 71. 
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Compressed Format Backup files are typically generated for archiving or 
giving to another user. Compressed format backup files include the .RSP and 
all database files for the project compressed into a single .RP1 file. Any auto-
backup files that may be included in the project folder are not included in the 
compressed backup. To generate a compressed-format backup file, select 
File > Backup Project.

To restore an auto-backup file or a compressed format backup file, simply 
select File > Open and open the .RSP backup file or the .RP1 file. 

Crash recovery 
If you experience a power interruption, RSLogix 5 provides you with a recent 
backup file containing current edits.
RSLogix 5 automatically background saves your project while you are working 
with it. (Go to Tools > Options, Preferences tab to set the interval at which 
these AutoSaves occur.) This auto-generated recovery file (internal RSP file) is 
only available to you the next time you open a project if you have a system crash 
or your power is interrupted. When attempting to open a project after a power 
failure RSLogix 5 prompts you with two options. 

You can open the latest AutoSave version of the file. This retains all edits 
(with the exception of pending database edits) made up until the time of the 
last AutoSave before power failed. Once you save this file it becomes your 
working version.
You can revert to the last saved version of the file. This means that any 
editing you may have done between the time you last saved the file and the 
time of the system crash will be lost.

Shortcuts for ladder editing
RSLogix 5 provides several methods for rapidly entering instructions: Quick 
Key Mapping, ASCII editing, and A.I. Series style dot commands. 

Important You must have saved or closed the file you are working on at least 
one time for the auto-recovery process to work. Therefore, it is good 
practice to save the file immediately after beginning a new project. 
This ensures that your auto-recovery process can begin properly.
The AutoSave feature of RSLogix does not affect the database, and 
any pending changes to the database will not be retained using 
AutoSave.
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Quick Key Mapping 
To make your programming tasks faster, RSLogix 5 lets you map any available 
alphabetic key (A-Z) on your computer keyboard to a ladder logic 
programming instruction.
To assign quick keys:
1. Select View > Properties (make sure you have a program file window 

opened and active or you will not be able to select Properties from the 
View menu). Click the Quick Key Mapping tab. 

To use Quick Keys:
1. Click a rung number in the ladder window to insert your logic rungs 

before.
2. Select Edit > Quick Key Mode, or instead press [Ctrl-E] on your 

keyboard. This inserts an empty rung into your program and places the 
software in Quick Key Mode. Assigned keys are listed at the top of the 
Ladder View.

3. Type the alphabetic quick keys that you have assigned to instructions. The 
instructions will be placed on the rung in the order that you type their 
quick key assignments.

4. To exit Quick Key Mode, go to the Edit menu and deselect Quick Key 
Mode, or press [Ctrl-E] again. 

2. Double-click _Free 
anywhere in the 
Instruction column. 
(Or double-click an 
assigned instruction 
to change it.)

3. Click the arrow to 
open the list box.

4. Click the instruction 
you want to assign.
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ASCII editing 
ASCII Editing is a function of RSLogix 5 that lets you modify instructions 
using ASCII instruction mnemonics instead of having to modify instructions 
using the ladder editor.
To edit a rung: 
1. Select any instruction on the rung or the rung number and press [ / ]. 

Make sure you press the forward slash key rather than the backslash. You 
can also double-click the rung number to open the ASCII box.

2. An ASCII editing box opens. For a rung that already contains logic, the 
existing ASCII instructions appear in the box so you can edit them. As 
you type an instruction, a syntax guide appears to help you with the 
parameters.

3. Press [Enter] to accept your edits or you can press [Esc] to discard 
them.

Example ASCII rung
A sample rung is shown below in both graphical and ASCII format with lines 
showing which ASCII mnemonic corresponds to which part of the graphical 
rung. 

Cursor

Syntax guide
The parameter you need to 
enter next (or are entering) is 
highlighted in bold.

 BST XIC I:003/13 NXB XIO T4:20/DN BND XIO B3/33 TON T4:20 0.01 500 412 
BST = branch start
NXB = next branch
BND = branch end
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Dot commands 
In A.I. Series software dot commands provided a very rapid means of not only 
editing ladder logic, but also accessing various functions of the software such 
as Advanced Diagnostics search or Who Active. RSLogix 5 emulates the A.I. 
Series Command Portal. 
To use dot commands in RSLogix 5:
1. Press [Alt-.], that is, hold down the Alt key and press the period.
2. Type in the shortcut command. For example, type EI (Edit Insert) to 

insert a rung.

3. Press [Enter].
For a list of dot commands refer to the online help. Select Help > Contents. 
Click the Index tab and type dot commands. Click Display.

Other shortcuts and tips
Remember to use the right mouse button to access functionality whenever 
possible. The right mouse button provides you with context menus that list 
editing options. Keyboard users can press [Shift + F10] to access a right mouse 
menu. 
Remember that you can press [F1] (or click the Help button when available) 
on any instruction, or within any window to access help. For more information 
about online help see Chapter 10, Getting the information you need on page 99.

Selecting multiple rungs  
You can select multiple rungs by holding down the Ctrl key and clicking the left 
mouse button on every rung you want to select. You can also select a range of 
rungs by holding down the Shift key and clicking the beginning rung and 
ending rung.

Jumping to a rung 
You can jump to any rung in your project by selecting Search > Goto. You can 
go to a rung in the current program file or you can go to a rung in another 
program file within the same project. You can also press [Ctrl + G] to access 
the Goto Rung dialog.

Tip You can combine dot commands with ASCII editing to rapidly enter 
ladder logic. Press [Alt - .], type EI, EA, or ER to insert, append, or 
replace a rung, type a forward slash ( / ) without a space before it, 
type the ASCII rung, and press [Enter]. For example, 
EI/XIC I:001/1 OTE O:002/5.
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Keyboard shortcuts   
A list of hot keys (keyboard shortcuts) that enable you to maneuver the 
software without a mouse can be found in a help file that you can print out. To 
access this file, expand the Help folder in the project tree, and then double-
click on Using The Keyboard. 

Addressing
You can use several different methods to address instructions. You can enter 
an address by: 

manually typing it in
dragging addresses from data files
using copy and paste from program to program

Branching  

Add a branch  
Click this button on the instruction toolbar to place a branch in your ladder 
logic. If your cursor is on an instruction, the branch is placed immediately to 
the right of the instruction. If your cursor is on the rung number, the branch is 
placed first on the rung.

Move a branch 
Click on the upper left corner of a branch and drag to move the entire branch 
structure to another location in your ladder logic program. Valid release points 
will be visible on the ladder display.

Expand a branch 
Click the right leg of the branch, then drag the leg to the right or left. Valid 
release points will be visible on the ladder display.

Tip You can drag-and-drop rungs, branches, instructions, and addresses 
from file to file or from the database to a file. To drag-and-drop, 
position the mouse pointer over a file element, click and hold down 
the left mouse button and drag the element to another location, and 
then release the mouse button. Red boxes indicate valid locations; 
these turn green when properly selected. 
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Nested branches 
Place the cursor at the upper left corner of a branch leg, right-click, and select 
Append New Branch to place another branch structure within the original 
branch structure.

Parallel branches 
Place the cursor at the bottom left corner of a branch leg, right-click, and select 
Extend Branch Up or Extend Branch Down.

Copy branch leg 
Click on the left edge of the branch leg you want to copy. In the picture at the 
left, this is the center leg. Right-click and select Copy. Finally right-click on a 
rung or instruction in your logic and select Paste to insert the rung leg. 

Copy entire branch structure 
Select the right leg of the branch structure, right-click and select Copy. Finally 
click on a rung or instruction in your logic and select Paste from the right 
mouse menu to insert the rung structure.

Delete a branch 
Place the cursor at any location on the branch and click the right mouse button. 
Select Delete. If you cut or delete a branch, all instructions on the branch are 
also deleted.

Undo operation 
The undo button reverses your last action. You can use this button to walk 
through (and undo) your previous actions one at a time. RSLogix 5 remembers 
up to 200 previous actions.
If you want to undo a move operation, you must click undo twice. This is 
because RSLogix 5 considers a move a series of two actions (copy and cut). You 
have to let RSLogix know that you want both the copy and the cut undone. If 
you click undo only one time when trying to undo a move, the move appears 
to be a copy, and you will see the moved element appear at both locations. 

Online editing 
The online editing function lets you monitor and correct your ladder program 
when your programming terminal is connected to a PLC-5 processor. Online 
editing functions consist of inserting, replacing, and deleting rungs in an 
existing ladder program while online with the processor. 
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While multiple terminals may be simultaneously connected to the same 
processor, only one programming device at a time can perform online edits of 
the program. The response of other terminals to a processor edit depends on 
the processor type and firmware revision. For all Classic and older New 
Platform PLC-5 processors, the other terminals will be forced offline and must 
upload the entire program again. For later New Platform revisions, the other 
terminals will remain online while the changed program file is automatically 
uploaded in the background.
Within your logic program RSLogix 5 places edit zone markers in the margin 
to the left of the left rail. These letters signify edit zones and they indicate the 
type of ladder program edit. 
Lower case zone markers indicate edits that exist only in the computer memory. 
Upper case zone markers indicate edits that exist in the processor memory. 
After successfully assembling the edited rungs, the zone markers disappear. 

Lower-case zone markers  

Tip You can search for zone markers in your project the same way you 
might search for an instruction or an address. Select Search > Find. 
Click Rung Zones and select the type of edit zone you want to 
search for.

e (Offline and online) These rungs are currently under edit within the 
computer RAM. If you are working offline, after a successful program 
verification the lower-case e will disappear and the edits will be 
incorporated into the program. If you are working online, after accepting 
the rung, the lower-case e will be replaced by an upper-case I indicating 
that the rung is now in the controller's memory and will be inserted into 
the program file. 

i (Online) These rungs are to be inserted into the program. Rungs marked 
with a lower-case i currently exist in the computer memory and will not 
be entered into the controller until the rung is accepted. After the rung is 
accepted, the lower-case i is replaced by an upper-case I. 

r (Online) These rungs are to be replaced in the ladder program. Rungs 
marked with a lower-case r currently exist in the computer memory and 
will not be entered into the controller until the rung is accepted. An r 
marked rung is always preceded by an e marked rung. After the rung is 
accepted, the lower-case r will be replaced by an upper-case R. 
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Upper-case zone markers 

Online editing example
This example replaces an XIC instruction with an XIO instruction with the 
same address while online. 
1. Select the rung in the program that requires editing and then select Edit > 

Rung Edits > Start Rung Edits or double-click the rung number. A 
duplicate of the selected rung (preceded by the e edit zone marker) is 
shown in your program, with the original rung marked with r. See the 
example below. 

d (Online) These rungs are to be deleted from the ladder program. Rungs 
marked with a lower-case d indicate a deletion reflected in the computer 
memory. This deletion will not be reflected in the controller until the rung 
is accepted, at which time it will be replaced by an upper-case D. 

I (Online)  These rungs have been inserted in the controller's logic 
program. You can test the edits by selecting Edit > Online Edits > Test 
Edits to see how the rung works in the online ladder program. Click 
Assemble Edits to finalize the rung insertion and complete the editing 
process. (The Test Edits and Assemble Edits functions are also available 
by right-clicking on the rung number.)  

R (Online)  These rungs have been replaced in the controller's logic 
program. Rungs marked with an upper-case R continue to function in the 
program until you select Test Edits to see how the new rung works in 
the online program. Select Assemble Edits to finalize the replacement 
and complete the editing process. 

D (Online) These rungs have been deleted in the controller's logic program. 
Rungs marked with an upper-case D continue to function in the program 
until you select Test Edits to see how the program functions without the 
rungs in the online program. Select Assemble Edits to finalize the 
deletion and complete the editing process. 

Edits are made on the duplicate 
rung, marked e.

r marks the original rung, which 
will be replaced by the edit rung.
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2. Make the edits to the rung. The lower-case edit markers do not change 
since they represent changes that only exist in the computer memory; 
these changes are not yet a part of the online program in the controller. 
(At this step you can select Cancel Rung Edits to cancel the edits you 
have made to the rung.)

3. Select Edits > Rung Edits > Accept Rung (or right-click the rung 
number and select Accept Rung Edits). This changes the edit zone 
markers and places both rungs in the controller memory. 

At this point you can still right-click the I-marked rung and select Cancel 
Edits to cancel the accepted I-marked rung and retain the originally 
programmed R-marked rung instead.

4. Select Test Edits. The I-marked rung takes precedence. The program in 
the controller will operate with the inserted rung, and the R-marked rung 
will be ignored. 

5. Select Assemble Edits. All edit zone markers disappear and the edits are 
incorporated into the online program. There is no Undo option after 
online edits have been assembled. 
Going from online to offline with rungs under edit removes the online 
edits in RAM. Make sure you have accepted edits before going offline if 
you want any changes retained in the processor.

Online editing restrictions
During an online editing session you cannot:

resize data table files
create or delete program files 
change program file protection

The upper-case I represents the 
rung that has been inserted into 
the online program.

The upper-case R represents the 
online rung that is to be replaced. 
At this time the R rung is still 
operating in the program.
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Configuring MCPs (Main Control Programs) 
As many as 16 MCPs can run simultaneously. MCPs may be any mix of ladder 
files, SFC files, or structured text files.
To configure MCPs:
1. Double-click the S2 data file icon in the project tree.
2. Click the MCP tab. Specify which program files will function as MCPs by 

typing their file numbers in the Program File column(s). 
3. Click in the checkboxes to indicate whether each MCP is to be enabled or 

disabled, and whether you want to skip the I/O scan at the end of the 
MCP’s execution. 

You can view scan time data for executing main control programs on the Scan 
Times tab of the S2 status file.

Configuring Interrupts

STI (Selectable Timed Interrupt)   
A Selectable Timed Interrupt (STI) causes the processor to periodically 
interrupt program execution to run an STI program once to completion. 
Afterwards, the processor resumes executing the original program file from the 
point where it was interrupted.
Select a program file for the STI by double-clicking the Processor Status icon 
in the Controller folder in the project tree. Then click the STI tab (you may 
need to use the arrow buttons to see more tabs) and enter the information 
needed to define the STI. Press the Help button if you need more information.

PII (Processor Input Interrupt)   
A Processor Input Interrupt (PII) specifies when an event-driven input causes 
the processor to interrupt program execution and run a PII program once to 
completion. After the PII executes, the processor resumes executing the 
program file from the point where it was interrupted. 

Caution When an MCP is disabled, outputs remain in the state that they were 
in during the last scan (that is, all actions remain active). Make sure 
that you consider any outputs that might be controlled within that 
MCP before disabling it; otherwise injury to personnel or damage to 
equipment may result.
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Select a program file for the PII by double-clicking the Processor Status icon 
in the Controller folder in the project tree. Then click the PII tab (you may need 
to use the arrow buttons to see more tabs) and enter the information needed to 
define the PII. Press the Help button if you need more information.

Using the structured text editor 
Structured text is only supported on Enhanced (New Platform) PLC-5® series 
C, revision C and later processors. 
Structured text is an English–like set of instructions and mnemonics that you 
can use to perform most of the same tasks that you already perform with ladder 
logic. The structured text language resembles BASIC and is based on the 
International Electrotechnical Commission (IEC) 1131–3 standard for 
programmable controller software.
Use structured text as an alternative to, or in conjunction with, ladder logic or 
Sequential Function Charts (SFCs). Structured text supports complex 
expressions and both logical and symbolic addressing. Use structured text or 
ladder logic to program MCPs, subroutines, or actions and/or transitions in 
SFCs, depending on which type of programming best suits your application 
and how much memory you have available.
To learn more about creating structured text files, click the Help menu in 
RSLogix 5, select Contents, and then double-click the Structured Text Editor 
book in the Contents tab.

Using the sequential function chart (SFC) editor 
Sequential Function Chart (SFC) programming is a method of programming 
complex control systems at a more highly structured level. An SFC program is 
an overview of the control system, in which the basic building blocks are entire 
program files. Each program file is created using familiar ladder logic. The SFC 
approach coordinates large, complicated programming tasks into smaller, more 
manageable tasks.
To learn more about creating sequential function chart files, click the Help 
menu in RSLogix 5, select Contents, and then double-click the Sequential 
Function Chart (SFC) Editor book in the Contents tab.
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Introduction 
In addition to allowing you to view changing data by opening multiple data 
table windows, RSLogix 5 provides you with several customized methods for 
monitoring data. 

Cross Reference
Forces
Custom Data Monitor
Recipe Monitor
Custom Graphical Monitor
Histograms
Trending

The custom data monitor (CDM) file lets you compose lists of addresses that 
you monitor frequently, or lists of addresses with interrelated functionality, so 
that you can view, document, protect, or even force the changing data values 
from a single source file.
When you are online, you can use histograms and trends to see how your 
program is behaving over time, by examining bits as the program runs in the 
PLC-5 processor. A trend logs the data for more than one address (typically 
related) over a period of time. Contrast this with a histogram which logs the 
data contained in a single address over a period of time. 

Chapter

7 More about monitoring 
data
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Cross Reference 
A Cross Reference Report lists all logical addresses in your project and gives 
the location of every occurrence of each address. The report includes the 
following data: address, symbol, instruction mnemonic, file # (and name), and 
rung #. You can sort the Cross Reference Report by symbol or by address. 

Display a Cross Reference Report in one of two ways:
Double-click the Cross Reference icon in the project tree (in the Data Files 
folder).
Right-click an address in your ladder logic and select Cross Reference. The 
same report displays, but the address you had selected is highlighted.

As an alternative to a Cross Reference Report, you can choose to display cross 
reference information right on the ladder view. To use this feature, select View 
> Properties, and click the Address Display tab. Make sure either or both 
checkboxes are checked in the Cross Reference Display area of the dialog.

Tip You can disable cross references to get online faster. Select Tools > 
Options. Click the XRef/Address Wizard tab and uncheck the 
Enable Cross Reference Online box.
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Forces 

To monitor forces, double-click the input or output force file in the project 
tree.
You can also use the Forces dialog to install and enable or disable forces while 
you are monitoring your file offline, or in any processor mode while monitoring 
your file online. Use the right-click menu on a bit in the Forces dialog to force 
the bit on or off. For more information about forcing, refer to the online help. 

Custom Data Monitor (CDM) 
The Custom Data Monitor function can be used to monitor bit addresses and 
word addresses. 
Addresses in a custom data monitor list can come from any data table file. They 
do not have to be from the same data table file.
Features of the custom data monitor include:

CDM lists can contain any type of address. If you enter the address of a 
structure, such as a timer, you can expand it to show all of its members.
CDM lists can contain ASCII comments to help you clarify bit or word 
listings, or annotate the CDM file.
You can define up to 256 (CDM) lists per project (0-255, inclusive). 
The CDM name is limited to 20 characters. 
The CDM description is limited to 59 characters. 
You can click and drag addresses from the data tables and the ladder logic to 
the CDM.
You can use the [Ctrl] and [Shift] accelerator keys to drag more than one 
address at a time from the data tables.
You can edit address descriptions from the CDM.

To access the Custom Data Monitor feature, double-click the CDM file icon 
located in the project tree. 

Caution All force functions can result in sudden machine movement, 
possibly injuring personnel or equipment. USE EXTREME 
CAUTION WHEN USING FORCES!

By default an untitled CDM file (#0) is included 
in your project. Rename this file when you add 
your addresses.

To create a new CDM file, right-click the 
Custom Data Monitors folder and select New.
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To insert additional addresses or symbols in the monitor list press [Insert]. A 
new row will open and you can type in or drag an address from your ladder 
program or data table into the empty Address slot. The current value of that 
address is listed in the Value column to the right of the address. If a description 
has been assigned to that address, it is also displayed.
For more information about using Custom Data Monitor, press [F1] while the 
CDM window is active.

Recipe Monitor 
The Recipe Monitor is a variation of the Custom Data Monitor. The Recipe 
Monitor is used specifically for monitoring groups of related indirect addresses 
with a common index. 
Many PLC projects contain data tables in which each element is relevant for a 
different mode of operation. When these data tables are grouped such that 
element 1 of each file corresponds to mode 1 of the assembly line used to make 
product 1, this is referred to as a “recipe”. The easiest way to keep track of 
recipes is to use a common reference address with indirect addresses to each of 
the related data files. The Recipe Monitor provides an easy and intuitive 
interface for this type of application.
To access the Recipe Monitor feature, double-click the Recipe file icon located 
in the project tree. 

For more information on the Recipe Monitor press [F1] while the Recipe 
window is active.

By default an untitled Recipe Monitor file (#0) is 
included in your project. Right-click and select 
Properties to rename this file.

To create a new Recipe Monitor file, right-click the 
Recipe Monitors folder and select New.

Drag a data file from the 
project tree to the 
Recipe Monitor. Note 
that an asterisk ( * ) 
represents the indexed 
part of the address. 
If you type in or drag an 
address from the ladder, 
be sure to use an 
asterisk to indicate the 
indexed part.

Set the index value.
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Custom Graphical Monitor 
The Custom Graphical Monitor provides the data monitoring of a Custom 
Data Monitor, but in an easy to interpret graphical representation. The Custom 
Graphical Monitor is a form on which you can place ActiveX controls for 
buttons, sliders, gauges, and charts as well as text and imported images. As is 
typical of ActiveX controls, you place and configure controls with the form in 
Design mode and switch to Run mode to activate the controls.
To access the Custom Graphical Monitor feature, double-click the CGI file 
icon located in the project tree. 

Histograms 
Use the histogram functionality in RSLogix 5 to get information about how an 
address's data value changes over time. 

By default an untitled Custom Graphical Monitor file 
(#0) is included in your project. Right-click and select 
Properties to rename this file.

To create a new Custom Graphical Monitor file, right-
click the Custom Graphical Monitors folder and 
select New.
{Click one of these buttons 

to add text, buttons, 
sliders, gauges, images, 
or graphs to the form.

Click here to toggle 
between Run and 
Design mode.

Displays the 
current mode.

Drag an address from 
the ladder or data table 
to a control.

Right-click a control and select Properties to change 
colors, define ranges, and set other options.
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You must be online with the PLC-5 processor to access the histogram function. 
Select Comms > Histogram to display the Histogram dialog. 

By clicking Start on this dialog, the histogram function sends a message to the 
PLC-5 processor to begin logging data. Each time the address value changes, 
the processor stores the value for the address in a histogram buffer, logging 
both the new value and the time interval between value changes. This data is 
represented in the top portion of the histogram display window.
If you frequently log certain data, you can save the configuration and simply 
load it without having to enter new parameters each time. Use Save Config and 
Load Config, accessible from the right mouse menu, for this functionality.

Trends 
A trend logs the data for more than one address (typically related) over a period 
of time. Contrast this with a histogram which logs the data contained in a single 
address over a period of time. 
This option provides the features of the RSTrendX Viewer plus remote 
trending capability. The RSTrendX Viewer is an ActiveX control for displaying 
process data in a trend or strip chart recorder format. It is based on the Viewer 
display in the RSTrend Data Acquisition and Trending software. 

Enter the address you 
want to track.

Select a time base for the histogram (in 
seconds).
If you don’t see data values changing, 
the time base may be inappropriate for 
the address you are monitoring.

Histogram

Timing Chart
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To create a trend chart:
1. Right-click the Trends folder in the project tree and select New.
2. Type a name for your trend chart in the Trend Name field. Then click OK 

to create an empty chart. The name can be up to 80 characters in length. 
An icon for the new chart appears under the Trends folder in the project 
tree. Whenever you want to open the trend chart double-click the icon. 
Trends are saved with the project. Logged data is not retained. 

You can create a trend configuration while offline or online. You must be 
online to trend data.
The following example shows a Trend for a timer T4:9. 

The legend at the left side of the display window contains:
A colored box representing the pen color. The color can be changed by 
double-clicking on the box and then selecting a new color from the available 
color chart.
The symbol name identifying the pen. In the display above, no symbol was 
defined for any of the addresses so the address is displayed instead.
The engineering units if they are defined. N/A means this is currently not 
available (not defined) for the selected pen.

Drag addresses, rungs 
or symbols to the chart 
from the data tables, 
ladder logic, 
Address/Symbol editor, 
or Address/Symbol 
picker.

Right-click on the graph and select Chart Properties to configure the chart. 

Tip To access the TrendX help file for more detailed information, right-
click on the chart and select Chart Properties. Click Help. This 
opens the TrendX help topic for the Properties General tab. Click 
the Help Topics button to browse the TrendX help table of 
contents or index.
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Introduction
PC5 library files are ASCII text files of the processor memory that contain the 
ladder logic, SFC files, structured text, data table files, and force tables. By 
exporting (saving to file) and importing (loading into a new project) these PC5 
files, you can reuse existing work. PC5 files can be opened in any ASCII text 
editor and modified for use in your projects. 

Things to remember about library files
Only verified project data can be saved to a .PC5 file.
Exported PC5 libraries can contain symbols that are 20 characters in length. 
When importing a PC5 library to PLC-5 A.I. Series, symbols will be 
truncated to 15 characters. For example, the symbol name 
UNLOAD_STRING_INDEX would be truncated as 
UNLOAD_STRING_I. 
Graphics characters are not allowed.
If importing into PLC-5 A.I. Series or 6200 Series software, the name of the 
.PC5 file is limited to eight characters. If importing into 6200 Series software, 
use only A-Z, 0-9, or the underscore character.
The file extension of the ASCII processor memory file must be PC5.
You cannot import or export a CAR (custom application routine) file.
If you are using passwords and privileges, the privilege configuration 
information is encrypted in the exported file to help make unauthorized 
access difficult.
The text editor you use with an ASCII text file must produce only printable 
ASCII characters, with no control characters or hidden characters.

Chapter

8 Saving and loading 
processor memory in 
PC5 libraries
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Exporting libraries
You can save entire projects or partial libraries. 
To save a library:
1. If you want to save a partial library, select the rungs you want to save. For 

a full save, skip this step. 
2. Either right-click the rungs and select Copy to PC5 Library, or select 

Edit > Copy To File. 
3. Supply the path and filename, and click Save.
4. Select the options you want for the export on the Export PC5 Format 

dialog and click OK. 

Importing libraries
Importing a .PC5 library allows you to reuse existing work by loading portions 
of ladder logic that were previously exported, into the current file that you have 
opened on your computer. Importing a .PC5 library converts the processor 
memory file, previously exported as a .PC5 ASCII file, to the RSLogix 5 .RSP 
format. 
To import a library:
1. Open the project into which you want to load the library. If you are 

loading a complete program image into an existing project, data table 
values in the library will overwrite values in the base program, and 
incoming rungs will be appended to existing program files.

Select whether you want to save the 
entire library or just part of it. To save part 
of it, you must have selected the rungs 
you want to save in Step 1.

Checking Annotate Library places 
additional information in the PC5 file about 
the rungs’ position in the original program. 
This information is used for 
troubleshooting a library file, and can help 
you if you intend to manually edit the PC5 
file in a text editor.

If you type a description here, it will appear 
at the bottom of the Open/Import dialog 
when you import the library.
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2. If you are loading a partial library, select the rung in your program that 
you want the library rungs to precede. The library rungs will always be 
placed before the rung you select. Data table values from the library will 
overwrite existing data table values for those addresses already present in 
the base project.

3. Select Edit > Paste From file. (Or right-click a rung and select Paste 
From PC5 Library.)

4. On the Open/Import dialog, select the file you want to import and click 
Open.

5. On the Import PC5 Format dialog you are asked to make some choices 
about how you want some of the imported files treated with regard to any 
existing documentation and addressing in the current file. 

6. Choose an Address Load Mode for the library and click OK. Click Help 
for more information. See the diagram below for information on the 
Indexed mode.

Choose the Indexed mode and then click Edit Index if you want 
to display a Fixup table from which you can adjust the addresses 
in the imported library so that there are no conflicts with the 
addresses in the base program.

If you change base address B3/5 to B3/10 (in the 
Fixup column) and press [Enter], the addresses 
relative to B3/5 change accordingly. Each relative 
address is offset by the change applied to the base 
address. In this example, relative address B3/9 
would change to B3/14, and so on. Relative 
addresses include all addresses in the list in the 
same data file up to the next base address. The 
address column continues to display addresses as 
they were before you made any changes. 

To change the address type, 
double-click it and select either 
Global, Relative, or Base. An 
address set to Global is not 
affected by indexing to a previous 
base address.
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Sample PC5 file
The following sample file is not a complete file. It has been condensed to show 
a sampling of each section. Read the section Creating or editing a PC5 ASCII text 
file on page 92 for more information about each section of the library file and 
information on comments (text enclosed between percent signs %).
The section identifiers in the left margin are not a part of the file, they have 
been included so that you can more easily identify each of the sections in the 
PC5 library file.

Program Header START PLC5_40VL SERIES_C REV_C COMPLETE

Data Table DATA O:177
% O:000 % 0X0000 0X0000 0X0010 0X0000 0X0140 0X0000 0X0003 0X0000 
% O:010 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% O:020 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% O:030 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 

DATA I:037
% I:000 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% I:010 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% I:020 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% I:030 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
..
.
.

Project Name PROJECT "ICOM5DM7"
2  "MAIN_LADDR"
3  "PID_SUB_RT"
4  "SUB_RT_2"
6  "SUB_RT_4"
7  "BITMAP_CHT"
8  "TREND"
9  "WHEELPROG"
10  "WINVIEW"
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Program Files LADDER 2
% Rung: 0 %
SOR XIC B3/0 XIC I:002/1 OTE O:004/0 EOR 
% TITLE/RUNG DESCRIPTION  ATTACHED TO:RUNG
TITLE:Start Up Diagnostic Check
RUNG DESCRIPTION:

Sample Rung Description 
Rung Descriptions can be up to 64K bytes per rung, with 200 lines displayed
The first rung description might explain the program or give useful information
%

% Rung: 1 %
SOR BST XIC I:003/4 NXB XIO T4:5/DN BND XIC B3/10 TON T4:5 1.0 450 315 EOR 
% Rung: 2 %
SOR XIO T4:9/DN XIC B3/96 TON T4:9 0.01 150 17 EOR 
% Rung: 3 %
SOR LIM 1 T4:9.ACC 40 OTE B3/0 EOR 
% Rung: 4 %
SOR XIC T4:3/EN XIC I:003/0 OTE B3/65 EOR 
% Rung: 5 %
SOR XIC B3/28 BST OTE B3/88 NXB OTE O:004/6 BND EOR 
% Rung: 6 %
SOR BST XIC B3/33 NXB XIO T4:0/DN BND TON T4:0 0.01 500 473 EOR 
.
.
.

Force Table FORCE FO:177
% ON     OFF  %
0X0000 0X0000 % FO:000 %
0X0000 0X0000 % FO:001 %
0X0000 0X0000 % FO:002 %
0X0000 0X0000 % FO:003 %
0X0000 0X0000 % FO:004 %
0X0000 0X0000 % FO:005 %
0X0000 0X0000 % FO:006 %
0X0000 0X0000 % FO:007 %
0X0000 0X0000 % FO:010 %
0X0000 0X0000 % FO:011 %
0X0000 0X0000 % FO:012 %
0X0000 0X0000 % FO:013 %
0X0000 0X0000 % FO:014 %
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0X0000 0X0000 % FO:015 %
0X0000 0X0000 % FO:016 %
.
.
.

Channel Config CONFIG $4:2:-1

CONFIG $4:0:347
% $4:0:0 %

-1 -1 26688 7175 18954 7717 -1 -1 26688 7175 
% $4:0:10 %
18954 7717     -1     -1 26688 7175 18954 7717 -1  -1 

% $4:0:20 %
 26688 7175 18954 7717 0 0 0 0 0 0 
% $4:0:30 %

0 0 0 0 0 0 0 0 0 0 
% $4:0:40 %

0 0 0 0 0 0 0 0 0 0 
% $4:0:50 %

0 0 0 0 0 0 0 0 0 0 
.
.
.

Creating or editing a PC5 ASCII text file
A PC5 library file contains six sections: program header, data table, project 
name, program files, force table, and channel configuration. 

Specifying the program header
The first section of a PC5 file is the program header. The program header is a 
single line that contains: 

the processor type
the processor series
the processor revision

When you perform an export, the program header line contains the word 
COMPLETE or PARTIAL. This indicates whether the library contents include a 
complete program file or whether a partial library was saved. Every ASCII file 
must have a program header section, even if all the remaining sections are 
empty.
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The following program header identifies the processor as a PLC-5/15 series B 
revision A and specifies the library as a complete processor memory file.
START PLC5_15 SERIES_B REV_A COMPLETE

Specifying the data table
The second section of a PC5 file defines the data table. The data table is the list 
of data table files that the processor uses. Files are defined by: 

the word DATA (upper or lower case)
a letter indicating the file type
the file number
the last address defined in the file

Use a separate section for each data table file.
The following data table entry specifies binary file 3 containing 8 words (0-7). 
The values on the line following the data table entry specify the data values.

DATA B3:7
0 1 2 3 4 5 6 7

Specifying the project name
The third section defines the project name and program file names. The project 
name is always stored in program file 0. 
The following entry specifies DRILL1 as the project name of a processor 
memory file and MAIN_LADDR as the name of program file 2. The project 
name and program names must be enclosed in quotes and can contain up to 8 
characters (A-Z, 0-9, underscore _ and blank spaces).

PROJECT "DRILL1"
2  "MAIN_LADDR"

Specifying the program files
The fourth section defines the program files. Each program file can contain 
sequential function charts, ladder, or structured text programs. Each program 
file can have zero or more rungs. Each element and branch in a rung is 
represented by a mnemonic along with required data or address information. 
The following entry defines ladder program file 3. The word LADDER (upper 
or lower case) starts the section with the program file number following. Each 
line that starts with an SOR instruction indicates the start of a rung of ladder 
logic; the EOR instruction indicates the end of a rung.
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LADDER 3
SOR XIO I:030/3 XIC I:030/4 TON T4:10 1.0 32000 0 EOR
SOR XIC I:030/3 MOV T4:10.ACC T4:10.PRE EOR

Specifying the force table
The fifth section defines the force table. The force table defines inputs and 
outputs which are forced into an on or off state. If this section is not included 
no forces are applied. 
The following force table shows the force status for output address O:057. The 
force table is twice the size of the input/output image table. 
The force file below is commented. Placing comments, enclosed by percent 
signs (%), is for your reference only. They are not imported into the processor 
or database. 

FORCE FO:057
% ON     OFF  %
0X0000 0X0000 % FO:000  %
0X0000 0X0000 % FO:001  %
0X0000 0X0000 % FO:002  %

Specifying the channel configuration
The sixth section defines channel configuration data. This section contains 
channel configuration information as well as password and privilege and 
control net information. The lengths of each configuration section are variable 
depending on the configuration of the channel (i.e. channel zero will have more 
information than a DH+ channel). 

CONFIG $4:1:411
-1  -1 8224 8224 8224 8224 -1 -1 8224 8224

8224 8224  -1  -1 8224 8224 8224 8224  -1  -1
8224 8224 8224 8224 257 257 -1 0 0 0

0 0 0 0 0 0 0 0 0 0

Annotating the PC5 file
You can place comments in the PC5 ASCII text file. Comments (text enclosed 
by percent signs %) are for your reference only. They are not imported into the 
processor or database. 
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RSLogix 5 comes in two editions: a Standard edition that provides basic ladder 
logic editing functions, and a Professional edition that provides additional 
functions to expand your automation solutions and make editing ladder logic 
simpler. This chapter briefly describes the features included in RSLogix 5 
Professional.

Microsoft® Visual Basic for Applications® support
RSLogix 5 Professional allows you to expand your automation solutions 
through Microsoft Visual Basic for Applications (VBA). VBA allows you add 
and edit Visual Basic code within the RSLogix 5 development environment. 
RSLogix 5 Professional includes an object model that you can access through 
VBA. VBA code created through RSLogix 5 Professional is stored in your 
projects’ .RSP files.
You can run VBA code with RSLogix 5 Standard – to create or edit VBA code 
you must use RSLogix 5 Professional.
See the manual titled RSLogix Automation Interface Reference Manual for more 
information about using VBA in your automation solutions. This manual is 
included with RSLogix 5 Professional.

Custom Graphical Monitor
The Custom Graphical Monitor provides graphical data monitoring for your 
projects. In the Custom Graphical Monitor, you can place graphical buttons, 
sliders, gauges, charts, text, and imported images. 
See Custom Graphical Monitor on page 83 for more information about using this 
feature.

Chapter
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Editing project databases using Microsoft® Excel®

RSLogix 5 Professional allows you to view and edit project databases with 
Microsoft Excel software. Microsoft Excel 97 (and later versions) comes with 
an ActiveX control that RSLogix 5 can use. You must have Microsoft Excel 
installed on the same computer as RSLogix 5 Professional to use this feature.
The Microsoft Excel ActiveX control gives you the powerful editing features 
of Excel, such as search/replace, and modifying multiple records at the same 
time. Using this control minimizes or eliminates the need for database import/
export operations.
To access the Excel editor, click Tools > Database > Edit Using Excel. The 
Address/Symbol Editor will open using Excel as the editing tool. 
Pressing [F1] will access the Microsoft Excel Help system. 
When the Excel editor is displayed and has focus, RSLogix 5 displays the Excel 
menus and toolbars. You can also access Excel functions by using the right-
mouse button menus while working in the editor. 
Keep the following information in mind when using Excel to edit the database:

When you open the Excel editor, the entire contents of the Address/Symbol 
database is automatically loaded into the control. 
Changes made within the Excel editor will not be applied to the Address/
Symbol database until you click Apply or OK. When you apply changes, the 
entire Address/Symbol database will be overwritten with the contents of the 
Excel editor. 
Empty rows within the Excel editor are be ignored when applying the 
contents to the database. 
If records are added, removed, or moved within the Excel editor, they will 
be sorted when the contents are applied to the Address/Symbol database. 
When you click Apply or OK, all legal records will be written to the 
Address/Symbol database. Illegal records (records containing illegal 
characters, fields with too many characters, duplicate records, etc.) will not 
be written to the database. 
Any errors or illegal records encountered when applying the contents of the 
Excel editor to the database will be logged and displayed in a separate 
window. You have the option of saving this information to a file. 
If you close the Excel editor without clicking Apply or OK (by clicking 
Cancel), the editor closes without overwriting the database. Changes made 
in the editor since the last Update Changes operation will be lost. 
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The Excel editor is limited to approximately 64,000 rows per sheet. 
Databases with more than 50,000 records will have their contents spanned 
to multiple Excel sheets. 
All standard features of the Excel Active X control will be available to 
manipulate the database. When the Excel editor has focus, these features are 
accessed through the menus or toolbars or from the right-mouse menu. 
Remember, you can always get help with the Excel editor by pressing the 
[F1] key. 

Logic Trace
The Logic Trace feature lets you navigate through your ladder logic like using 
a Web browser. As you move your cursor through a ladder logic project, the 
Logic Trace feature keeps track of where you have been. You can then use the 
Logic Trace toolbar to navigate back to previous positions, or from earlier 
positions to later ones.
You can turn the logic trace toolbar on or off by clicking View > Toolbars and 
selecting or deselecting the Logic Trace toolbar. 

How logic trace works
As you move your cursor through the ladder logic, the software records the 
positions of your cursor. When no back or forward history is available, the logic 
trace arrow buttons are disabled (grayed out). 
Actions that create a “back” navigation history include cross reference 
navigation, program file display change, clicking your mouse on ladder logic 
rung/instruction elements, searching ladder logic, using the Goto Rung 
function, using dot commands, etc. Using the keyboard arrow keys will not 
generate a navigation history. 

Back button Forward button

Back menu Forward menu
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Actions that create a “forward” navigation history are limited to clicking an 
enabled “back” toolbar button or selecting a location from the “back” pull 
down menu. 
When you click a “back” button, the cursor will move to the previous location 
in the navigation history. Once you have moved backward in the navigation 
history, clicking the “forward” button will move the cursor forward through 
your navigation history. 
The pull down menus are limited to a maximum of 10 entries. Each entry lists 
a rung/instruction location. While the menus are limited to showing a 
maximum of 10 entries, the arrows allow you to go much farther back.
If you delete an instruction or rung that is in the history, that item is removed 
from the logic trace navigation history. If you edit a rung or instruction that is 
in the navigation history, it remains in the history. 
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Introduction
Use this chapter to review the sources of additional information on RSLogix 5 
software, including online help, RSLogix 5 training, and technical support. 
You can find out more information about RSLogix 5 software by consulting:

RSLogix 5 online help
RSLogix 5 training
Technical support services

RSLogix 5 online help
RSLogix 5 online help provides overviews, a description of the fields on every 
dialog box, and step-by-step procedures for working with all of the features of 
RSLogix 5. To open online help while running RSLogix 5 you can:

click the Help button on any window
press [F1] while the cursor is on any instruction, dialog box, or window view
select Help > Contents

expand the Help folder in the project tree and then double-click on any 
informative file listed (except for User Application Help which is only 
available if you have defined it) to launch a help file.

Using the Contents, Index, and Find tabs
To display the tabbed help dialog:

select Help > Contents and click the appropriate tab or
expand the Help folder in the project tree, double-click Contents, and click 
the appropriate tab 
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Contents 

Index
The index tab provides a list of guide words or subjects just like the index of a 
book. This is a quick way to find information about a specific topic. Follow the 
directions on the Index tab.

Find
If you don’t see what you are looking for in the contents or index, you can 
search the entire help file for all occurrences of a word. Follow the directions 
on the dialog to find a word.
The first time you click the Find tab you will see a message about building a 
word list. Follow the directions on the screen. The default selection is generally 
sufficient. For more information refer to Microsoft’s online help (Start > 
Help). 

Tip To print a group of help topics, select a book from the Contents tab, 
and then click the Print button. All of the individual topics in that 
book will print. 

To expand the outline, 
double-click a closed 
book.

To collapse the outline, 
double-click an open 
book.

To go to a topic, double-
click a page.

Double-click the 
Procedures book to see 
a list of all the tasks you 
can accomplish related 
to a specific function of 
the software.
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Instruction set help
Click any instruction in your project and press [F1] for help on that instruction. 
To pick an instruction from a list instead, select Help > PLC5 Instruction 
Help. From this topic you can also search for an instruction by category. 
Sample instructions are shown in the help with parameters entered so you can 
more easily determine what information (bit address, constant, etc.) you must 
supply.

Keyboard shortcuts
A list of hot keys (keyboard shortcuts) that enable you to maneuver the 
software without a mouse can be found in a help file that you can print out. To 
access this file, select Help > Using The Keyboard. To print any of the 
keyboard help topics, just click the Print button at the top of the window. 
Some of these keyboard shortcuts (sometimes called Ctrl-key accelerators) are 
standard to the Windows operating system and work across all Windows-based 
products. Other shortcuts will only work with the RSLogix 5 and 500 products. 

User Application Help
The User Application Help feature allows you to add your own reference 
source (document, web page, etc.) to the RSLogix 5 project. You can use 
whatever format you want for the source as long as the computer running 
RSLogix 5 can open and read that source. For example, you could use a 
Microsoft Word doc file, provided that you had Word on your computer. Or 
you could use an HTML file provided that you had a browser that could read 
the file. 
Your User Application Help file is saved with the project in RSLogix 5. You 
can specify one User Application Help file per project. 
To set up your User Application Help file:
1. Create the source file for your User Application Help. 
2. From the project tree in RSLogix 5, right-click User Application Help 

(under the Help folder) and select Properties. The User Application 
Help dialog appears. 

3. Enter the path and file name, or the URL for your source file and click 
OK. 

To specify a different source file, go back to the Properties dialog and enter the 
new path and name. 
To display the User Application Help file, double-click on User Application 
Help (under the Help folder in the project tree).
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Printing a popup help topic 

Learning more about using online help
To learn tips and tricks for getting the most out of the help system, select Help 
> Using Help.

RSLogix 5 training
Rockwell Software offers both classroom and computer-based training for 
RSLogix 5.

Classroom training
One of the best ways to increase your proficiency at using Rockwell Software 
products is to attend a Rockwell Software training program. Our training 
programs can help you master the basics and show you how to unleash the full 
potential of our software. 

To print the contents of a 
popup window, right-click 
in the popup and select 
Print Topic.
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We offer a wide range of training programs, from regularly scheduled classes 
conducted at Rockwell Software facilities, to custom-tailored classes conducted 
at your enterprise. The size of each class is kept small intentionally to maximize 
student engagement. 
For more information about our training programs:

visit our web site at www.software.rockwell.com/Training/

view the Support and Training help file either from Help on the menu bar 
or from the Help folder in the project tree.
contact the Rockwell Software Training Coordinator at 877-724-7864. 

Interactive training
A computer-based training program for RSLogix 5 is available for purchase. 
Contact your distributor to order RSTrainer 2000 for RSLogix 5. A demo of 
the training program is included on the RSLogix 5 CD-ROM. To run the demo, 
insert the RSLogix 5 CD-ROM into the CD-ROM drive. When the menu 
appears, select Try RSTrainer 2000 for RSLogix 5. 
If the CD-ROM does not autorun, open the Start menu and select Run. Type 
x:\autoplay (where x is your CD-ROM drive), and click OK. Select Try 
RSTrainer 2000 for RSLogix 5 from the menu.

Technical support services 
If you cannot find answers to your questions in the Getting Results with RSLogix 5 
publication or in the online help, you can call Rockwell Software technical 
support. 
Telephone—440-646-7800

Fax—440-646-7801

World Wide Web—www.software.rockwell.com/support

Support staff are available Monday to Friday 8 AM to 5 PM EST, CST, MST, 
and PST, except during U.S. holidays.

When you call
When you call, you should be at the computer running the Rockwell Software 
product and be prepared to provide the following information:

product serial number on the Activation disk labels (You can find the serial 
number online. On the RSLogix 5 menu, click Help, and then click About.)
product version number
hardware you are using
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Microsoft Windows operating system and service pack you are using
exact wording of any messages that appear on the screen
description of what happened, and what you were doing when the problem 
occurred
description of how you tried to solve the problem.
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Rockwell Software’s products are copy-protected. Only a computer with access 
to the activation key can run the software. The key is located in an activation 
file, which is originally located on the Master disk supplied with the RSLogix 5 
product. The activation file contains one activation key per product. Each key 
contains one or more licenses depending on how many copies of the product 
you have purchased.

During the setup process, the setup program gives you the opportunity to 
move the activation file from the Master disk to the root folder of the drive on 
which you’re installing the software.

Appendix

A EVMOVE Activation

RSLogix 5 software currently supports both the EVMOVE 
activation and FactoryTalk Activation systems for activating 
software. New installations of RSLogix 5 software must use the 
FactoryTalk Activation system. Older installations of RSLogix 5 
that have used the EVMOVE activation system may continue to 
do so.
Rockwell Software advises all RSLogix 5 users to upgrade their 
activation system to avoid problems with future releases of 
RSLogix 5.
This appendix applies only to the EVMOVE activation 
system. 

Store your Master disk in a safe place. If your activation becomes 
damaged, the Master disk may be the only means to run your 
software in an emergency.

Tip

Tip
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When you launch RSLogix 5, the software first checks your local hard drives, 
then network hard drives, and finally local floppy drives for activation. If the 
system fails to detect either the activation file or the Master disk, you will 
receive an error message stating that activation is required to run the RSLogix 
5 software.

Protecting your activation files

To avoid damaging your activation files, do not perform the following 
operations with activation files on the hard drive. 

Restore from backup
Upgrade the operating system
Compress or uncompress the hard drive 

Defragmentation utilities will not harm activation files.
Before running any type of utility that may modify the structure or organization 
of the hard drive, remove activation from the hard drive:
1. Use the Move Activation utility (EvMove) to move activation files from 

the hard drive to an activation disk.

Run EVMOVE.EXE from your hard drive (located in C:\Program 
Files\Rockwell Software\RSUtil if you accepted the default folder location 
during installation).

2. Perform the hard disk operation.

Systems attached to extensive networks can take quite a while to 
search for activation files on all available drives. You can use the 
CHECKDRIVES environment variable to specify and/or limit 
the drives your software checks for activation files and to specify 
the order in which they are checked. Refer to the activation 
utilities online help file by selecting Help > Copy Protection.

Tip

Certain anti-virus software packages, such as Norton Anti-virus, 
can corrupt the activation files. Configure your anti-virus 
software to avoid checking the files EVRSI.SYS and 
386SWAP.PAR.

Caution

Do not use the Move Activation utility if Rockwell Software 
products are currently running. Ensure all software programs are 
closed before initiating the EvMove utility.

Caution
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3. Move the activation files back to the hard drive.

Activating RSLogix 5
Depending on your needs, you can activate RSLogix 5 from any of the 
following:
Hard drive. The activation key resides on your computer’s hard disk. Use this 
method if you will typically use RSLogix 5 on only one computer. This is the 
default method if you activate RSLogix 5 during installation. To run RSLogix 5 
on a different computer, move the activation key back to the Master disk, and 
then to the hard drive of the new computer.
Diskette drive. The activation key resides on a floppy disk (activation disk). Use 
this method if you will typically use RSLogix 5 on more than one computer, for 
example, if you want to run RSLogix 5 on a desktop computer at some times 
and a portable computer at others.
Network drive. The activation keys reside on a network drive. Use this method 
if you have purchased multiple licenses of the software and want several users 
to be able to activate the software over a network. Refer to the online help for 
instructions on moving activation to a network drive (refer to the “Finding 
more information about activation” section in this chapter to access online 
help).

Running the activation utilities
The utilities for moving and resetting activation are called EvMove and Reset 
respectively. Reset is used when an activation file has been damaged. The 
EVMOVE.EXE and RESET.EXE files are located on your hard drive (located 
in C:\Program Files\Rockwell Software\RSUtil if you accepted the default 
folder location during installation). To run these programs, select Start > 
Progams > Rockwell Software > Utilities > Move Activation or Reset 
Activation.

You must use the move utility, EvMove, to move activation files. 
Attempts to copy, move or e-mail an activation file by other 
means will damage the file.

Caution
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Finding more information about activation
The online help (COPYPROT.HLP) provides more extensive information on 
activation including subjects such as:
KEYDISK. Set this environment variable to tell your computer to look for 
activation on floppy drives
CHECKDRIVES. Specify which drives to search for activation
network activation. Move activation to a network server to allow multiple 
users access to the activation
moving activation. See detailed instructions for moving activation
resetting activation. See detailed instructions for using the Reset utility to 
repair a damaged activation file
troubleshooting. Look up error messages, get problem-solving suggestions
You can access online help:

from the Help button on one of the EvMove or Reset dialog boxes.
from RSLogix 5 by selecting Help > Copy Protection from the main menu.
without running either RSLogix 5 or the activation utilities. From the 
Windows Start menu, select Programs > Rockwell Software > Utilities > 
Activation Help (if you accepted the default folder location during 
installation).

Some common questions
Following are some common problems that people encounter with activation 
and their solutions.

My activation files were damaged. What should I 
do?
If you have lost the activation because the activation file is damaged, you need 
to reset activation. Follow the Reset Codes instructions on the Rockwell 
Software Technical Support web page, or call the technical support telephone 
number. The web page and telephone number are both listed on the inside 
front cover of this guide.
If you cannot obtain a reset code immediately, follow these instructions to use 
the Master disk to activate the software as a temporary solution.
To use the Master disk to activate software:
1. Set the KEYDISK environment variable to TRUE. (Please refer to the 

online help.)
2. Insert your Master disk in the floppy drive.
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3. Run your software as usual. Your software will find the activation on the 
Master disk.

I accidentally deleted the software folder on my 
hard drive. Do I need to call Rockwell Software for 
replacement activation files?
No. Deleting the program files does not delete your activation. The activation 
files are not stored in the program folder; they are located in the root folder. 
Your activation files will not be lost unless you format the hard drive, tamper 
with hidden files in the root folder, or perform certain other hard drive 
operations (refer to the “Protecting your activation files” section in this chapter 
for more information).
To get the software running again, simply reinstall the software, but do not 
move the activation when given the opportunity.

Why can’t I move activation to a new floppy disk on 
a Windows NT system?
It has to do with a disk modification that NT does not allow. If you have access 
to a Windows 98 machine, you can create a disk that will work under NT. 
Format a floppy and move any activation file to it under Windows 98. (You can 
move the activation back off the disk if you want to keep it where it was.) Then 
take that disk to your Windows NT machine and move the activation to it.
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chassis • 54
chassis and I/O • 38
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discrete I/O • 57
MCP • 77
PII • 77
processor • 55
STI • 77
system communications • 35

controller communications • 43
ControlNet • 39
copy protection, see activation
crash recovery • 68
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data table file • 39
new project • 37
program file • 39

cross reference • 80
CSV files

importing • 61
CTD files • 61
custom data monitor • 81
custom graphical monitor • 83, 95
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D in rung margin • 75
d in rung margin • 75
data monitoring methods • 79
data table files
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database
adding documentation • 41
exporting • 62
import from A.I. • 50
importing • 59

database editor
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defined • 41

defragmentation utilities • 106
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branch • 73
deleting the software folder • 109
disk space required • 1
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documentation database
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documentation, see database
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download • 43
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drag and drop • 72
driver • 33
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DSC files • 60

E
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EAS file format • 63
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EIC file format • 64
entering ladder logic • 40
ERP file format • 63
error messages • 106
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EvMove • 107
EVMOVE activation • 2, 5
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CSV • 61
CTD • 61
data table monitoring • 44
DSC • 60
EAS • 62
EIC • 62
ERP • 62
ESG • 62
new data table file • 39
new program file • 39
new project • 37
OP$ • 60
OP$ files • 51
open A.I. or 6200 • 49
open multiple programs • 32
open project • 37
opening 6200 files • 50
RPD • 60

find • 44
forces, monitoring • 81

G

glossary • iv
go online • 43
go to rung • 71

H

hardware configuration • 53
hardware requirements • 1
help

see also online help
adding your own help document • 101
online • iii, 99
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difference from trends • 79

hot keys • 67, 72, 101
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I in rung margin • 75
i in rung margin • 74
I/O configuration • 38
I/O modules

adding • 56
importing

A.I. and 6200 Series files • 49

A.I. database • 50
database files • 59
PC5 libraries • 88

installing
RSLinx Classic Lite • 3
RSLogix 500 • 8
Security Server Client • 7

instruction toolbar • 31
instructions

help using • 101
quick entry • 68

K

keyboard shortcuts • 67, 72, 101
KEYDISK • 108

L

ladder editor • 40
ladder logic program • 40
ladder view • 30
laptop considerations • 43
letters in left margin • 74
libraries • 87
library, definition • iv
lists of bit and word addresses • 81
local directory • 5
logic trace • 97

M

main control programs • 77
master disk • 105
MCP, see main control programs
menu bar • 30
mnemonic, definition • iv
monitoring data • 44, 79, 95

cross reference • 80
custom data monitor • 81
custom graphical monitor • 83
forces • 81
histograms • 83
recipe monitor • 82
trends • 84

moving
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addresses • 72
instructions • 72

N

network
activation • 108

network directory • 5
node-locked activation • 6

O

online bar • 31
online editing • 73

example • 75
restrictions • 76
zone markers • 74

online help • 99
contents • 99
find • 99
index • 99
instruction set • 101
print popup • 102
print several topics • 100

Online Now • 46
OP$ files • 60
open

existing projects • 37
more than one project • 33
program files • 32

P

partial download • 43, 44
PC5 libraries • 87

annotating • 94
channel config portion of ASCII file • 94
data table portion of ASCII file • 93
editing ASCII text file • 92
exporting • 88
force table portion of ASCII file • 94
importing • 88
program files portion of ASCII file • 93
program header portion of ASCII file • 92
project name portion of ASCII file • 93
rules about libraries • 87
sample ASCII file • 90

PII, see processor input interrupt
policies • 16

printing see reports • 45
processor input interrupt • 77
program files

creating • 39
open multiple • 32

project tree
about • 31

projects
creating new • 37
definition • iv
open A.I. or 6200 file • 49
open existing • 37

Q

quick key mapping • 69
quick start steps

for development • 33
for maintenance • 46

R

R in rung margin • 75
r in rung margin • 74
recipe monitor • 82
recover after power loss • 68
replace • 44
reports

preview • 46
printing • 45

resetting activation • 108
restoring from backup • 106
results window • 30, 42
RPD files • 60
RSAssetSecurity • 4, 5, 8

importing database from Security Server • 
14

RSLinx Classic
configuring driver in • 33
version required • 2

RSLinx Classic Lite
installing • 3

RSWho • 35
rungs

copy and paste • 71
go to • 71
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selecting multiple • 71

S

search • 44
secured actions • 19
security policies • 16
Security Server

importing database into RSAssetSecurity • 
14

Security Server Client
installing • 7

selectable timed interrupt • 77
sequential function charts • 78
SFC editor • 78
Shortcuts

keyboard • 101
shortcuts • 67, 72

ASCII editing • 70
dot commands • 71
quick key mapping • 69

software requirements • 2
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